0

When I had installed the commerce in my development environment then the commerce authoring URL is set as https://commerceauthoring.sc930.local so my request goes to this URL when I click on the business tools. Now I want to move requests to go on https://localhost:5000 so what are the configs I need to follow?

The reason I want to have the business tools' request go on localhost:5000 because I am trying to connect the Commerce VS solution to the business tools as per this blog. And this can debug the plugin only for https://localhost:5000

0

Open \businesstoolsfolder\assets\config.json. Verify the EngineUri (Case sensitive) If that is correct, verify the config.json of your Visual Studio CE project.

Check the AllowedOrigins section and see if it has the right business tools url. Restart IIS.

Refresh your browser cache before opening business tools

If it still doesn't work then try:

Open the identity server folder in inetpub and goto the file--> SitecoreIdentityServer\Config\Production\Sitecore.Commerce.IdentityServer.Host.xml

Verify AllowedCORSOrigins setting. Check entry under AllowedCorsOriginsGroup2. It should have an entry for localhost:5000 combination. it is also case sensitive

| improve this answer | |
  • Thanks @sc.kautilya. Yes, it was a caching issue but I have updated the entry for the localhost:5000 in the AllowedCors but still, bizFx is blocking the localhost:5000 call. – Prashant Tomar Aug 11 at 18:56
  • check http vs https configuration. What is in the logs? – sc.kautilya Aug 11 at 18:58
  • I did 1. Entered the localhost:5000 in the identity server's Host.xml file and 2. Entered the same URL in the assets/config.json. – Prashant Tomar Aug 11 at 19:19
  • Did you restart identity server as well? – sc.kautilya Aug 11 at 19:30
  • Yes, even after that I checked in the private window. In the console of chrome, it is showing that bizfx.sc930.local has blocked the for localhost:5000 due to CORS policy. – Prashant Tomar Aug 12 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.