This is Sitecore 8.2 initial release. Im logged in as Admin, same result on items that has workflows or not.

I can't set publish restrictions as show in image. The warning shows and the version handling isn't working. Why can't I modify the item?

Sitecore displays a warning: You cannot change publish restrictions as you cannot modify the item.

On the affected item there are two visible warnings:

  1. You must lock this item before you can edit it
  2. This item is controlled by Unicorn

If I lock the item it just creates a new version of it.

Publish restriction image

  • 1
    What item are you trying to modify? Can you check if the item is protected? Nov 16 '16 at 9:56
  • None of the items are protected. It's the same for all items. The image shows an example of the error. Nov 16 '16 at 10:25
  • Yeah, but the reason can be on the item itself. See @Trayek's answer. Are there any informations/warnings on the item? Nov 16 '16 at 10:27
  • Visible warnings are: 1. You must lock this item before you can edit it (But then it just creates a new version of the item). 2. This item is controlled by Unicorn Nov 16 '16 at 10:30
  • If you are an admin, can you just unlock the item and see if it helps? Nov 16 '16 at 11:31

This might happen if the item is protected. You can verify this by clicking on an item in the content editor. You will see an information about item being protected.

enter image description here

If you are an admin you can unprotect the item and then be able to modify publish settings.

Further reading: http://contenttree.blogspot.com/2008/02/hiding-and-protecting-items.html


While Szymon's answer could be the cause, another possibility is that the item is actually locked by someone else.

Logged in as admin, but item locked by someone else

  • I'm trying to setup workflows for the site. No items are locked. Nov 16 '16 at 10:27

It seems like this item is configured to sync with Unicorn. When that is set, when you try to edit an item, Unicorn will try to write the into file system location.

Please check your set the Unicorn file path correctly and your app pool user has write permission to Unicorn folder location.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.