1

Since launching a v9.0.2 scaled site, I've seen this warning many times in the logs:

10076 09:52:45 WARN Session with Id xxxxxxx has reached the max page threshold of 50. If you see this message regularly, you should increase configuration parameter MaxPageIndexThreshold to avoid loss of valid data.

My understanding is that there are two potential solutions:

  1. Increase the MaxPageIndexThreshold
  2. Disable tracking of certain pages or API calls to reduce the total amount of page views being logged in Analytics

I want to consider the second solution before increasing MaxPageIndexThreshold. Specifically, I want to disable tracking of our custom API calls which don't need to be tracked.

Sitecore has a guide on how to do this, but it seems to only be for those using Sitecore Commerce.

Sitecore also has another guide, but it only works for the exclusion of files (rather than routes). I have confirmed that this is true. No route support.

This SO answer also makes a recommendation, but the code repo linked in that answer looks like it could use some improvements and more testing.

Here are a few more resources I've looked at:

Am I missing something? Is there a better way to do this?

1

Sitecore put that limit in there because the xConnect payload will become too large and start to cause timeouts on fill/save. So you can increase it, but with that risk.

Using the excludeUrlTracking is a possibility, and you can also disable the page in the Sitecore UI. From the toolbar Analyze > Attributes > Settings will allow you to tell Sitecore to ignore certain pages. Must be noted that this will also disable and goals you have on that page or any personalization on that page.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.