0

There was a query from Client that they are saying they have just created an item in master database. But without they publish it, it was exists in web database. I checked the following

  1. Checked if is there any publishing agent is configured, but it was disabled by set the interval="00:00:00".
  2. Checked if any item:saved or item:added events are extended to customize it. Nothing present
  3. Checked on the Publishing logs, it has no evidence for the item gets published because no logs presented about the item.
  4. Publishing.AutoScheduleSmartPublish is set to True and is configured for " /sitecore/templates/System/Templates/Template" template. So if this could be an issue then it should impact almost all the items right? but this is happening only for few items.

So please advise what else I need to look into it to troubleshoot the issue.

  • You can try enabling historyengine and verbose log for publishing(set traceToLog to true for Sitecore.Publishing.Pipelines.PublishItem.UpdateStatistics processor) to get detailed publishing logs. – navincumar Aug 25 '20 at 8:11
  • Thank you. Let me try this – Prabhu Ranganathan Aug 26 '20 at 5:01
0

I would look into logs (log.txt) and check each log entry related to the user who reported this activity, starting from user's login. This will tell what exactly the user was doing when the item got created.

I would also see if the issue can be reproduced or not. If yes, you can have better insights in your logs when the issue reproduces.

Look for any patches which can contain customisation causing this.

Also check if the content author has the capability to switch databases in Sitecore or not (in desktop mode). If yes, there are chances content author switched the context to web db for some purpose (may be validation) and ended up creating the item in Web db itself instead of Master db (unknowingly). This has happened couple of times in past with us.

  • No, Content authors created in master db only. Also this issue coming up for more than one authors and they are saying it occurs multiple times. For me, it is not reproducible. I checked the Publishing log with the date they have mentioned, but i couldn't see any log entry related to the item. – Prabhu Ranganathan Aug 25 '20 at 10:29
  • Did you try a user with same privileges as content author? Are they really looking for update into web db in Sitecore client or are they saying it based on what they are seeing on website? The website can be configured to use master db to serve content to live site.In such case, they can see changes on website without publishing it. – Ghanendra Singh Aug 25 '20 at 10:53
  • master and web databases are configured properly. CDs are serving from web database. This issue is not happening for all the items. only specific items randomly – Prabhu Ranganathan Aug 26 '20 at 5:03
  • 1
    Another think I can think of is workflow configured on those items. Workflows have the capability to publish the item to web db on approval (without actual publish). Logs shall have information related to this. Without access to logs or any additional information, it is bit difficult to diagnose. – Ghanendra Singh Aug 26 '20 at 5:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.