0

Sitecore 9.2

I am trying to run an ARM Template to install Sitecore to Azure China. I set the location parameter to "China East 2". When I run Start-SitecoreAzureDeployment, it creates the resource group properly in my Azure.cn instance, however then it then throws the error:

New-AzureRmResourceGroupDeployment : 3:03:44 PM - Error: Code=LocationNotAvailableForResourceType; Message=The
provided location 'westus' is not available for resource type 'Microsoft.Search/searchServices'. List of available
regions for the resource type is 'chinaeast2'.
At C:\Projects\mts.com\scripts\AzureInstall\tools\Sitecore.Cloud.Cmdlets.psm1:120 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception
    + FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
   loymentCmdlet

New-AzureRmResourceGroupDeployment : The deployment validation failed
At C:\Projects\xxxxxx\scripts\AzureInstall\tools\Sitecore.Cloud.Cmdlets.psm1:120 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : CloseError: (:) [New-AzureRmResourceGroupDeployment], InvalidOperationException
    + FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
   loymentCmdlet

It looks like the installation script is ignoring the location parameter and always installing to "westus" instead of using the parameter passed to Start-SitecoreAzureDeployment. How do I get around the westus location?

  • I'm not sure about the error message here, but you should take a look at the Azure Compatibility table: kb.sitecore.net/articles/617478 China regions are missing a lot of dependent services (like Azure Search which your error is about) – Jason St-Cyr Aug 31 at 11:10
  • In addition to Jason's message, please check how are you setting China East 2 in your parameter, give a shot by adding chinaeast2 instead – Vinicius Deschamps Aug 31 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.