0

I want to create a new JSS app but with older versions of angular and typescript.

I have version 11.0.2 for JSS

and when I run ng --version this is what I get

@angular-devkit/build-angular     0.12.4
@angular-devkit/build-optimizer   0.12.4
@angular-devkit/build-webpack     0.12.4
@angular-devkit/core              7.2.4
@angular-devkit/schematics        7.2.4
@angular/cli                      7.2.4
@ngtools/webpack                  7.2.4
@schematics/angular               7.2.4
@schematics/update                0.12.4
rxjs                              6.3.3
typescript                        3.2.2
webpack                           4.28.4

If I create a new JSS app with jss create new-app angular, this is what my package.json looks like.

  "dependencies": {
    "@angular/animations": "~8.2.8",
    "@angular/common": "~8.2.8",
    "@angular/compiler": "~8.2.8",
    "@angular/core": "~8.2.8",
    "@angular/forms": "~8.2.8",
    "@angular/http": "~7.2.15",
    "@angular/platform-browser": "~8.2.8",
    "@angular/platform-browser-dynamic": "~8.2.8",
    "@angular/platform-server": "~8.2.8",
    "@angular/router": "~8.2.8",
    "@nguniversal/module-map-ngfactory-loader": "~8.1.1",
    "@ngx-meta/core": "~7.0.0",
    "@ngx-translate/core": "~11.0.1",
    "@ngx-translate/http-loader": "~4.0.0",
    "@sitecore-jss/sitecore-jss": "^14.0.1",
    "@sitecore-jss/sitecore-jss-angular": "^14.0.1",
    "@sitecore-jss/sitecore-jss-tracking": "^14.0.1",
    "apollo-angular": "~1.7.0",
    "apollo-angular-link-http-batch": "~1.7.0",
    "apollo-angular-link-persisted": "~1.1.0",
    "apollo-cache-inmemory": "~1.6.3",
    "apollo-client": "~2.6.4",
    "apollo-link": "~1.2.6",
    "bootstrap": "^4.3.1",
    "core-js": "~3.2.1",
    "graphql": "14.5.8",
    "graphql-tag": "~2.10.0",
    "lodash": "^4.17.15",
    "rxjs": "~6.5.3",
    "tslib": "^1.10.0",
    "zone.js": "~0.10.2"
  },
  "devDependencies": {
    "@angular-devkit/build-angular": "^0.803.6",
    "@angular/cli": "~8.3.6",
    "@angular/compiler-cli": "~8.2.8",
    "@angular/language-service": "~8.2.8",
    "@sitecore-jss/sitecore-jss-angular-schematics": "^14.0.1",
    "@sitecore-jss/sitecore-jss-cli": "^14.0.1",
    "@sitecore-jss/sitecore-jss-dev-tools": "^14.0.1",
    "@sitecore-jss/sitecore-jss-manifest": "^14.0.1",
    "@types/jasmine": "~3.4.2",
    "@types/jasminewd2": "~2.0.8",
    "@types/node": "~12.7.9",
    "body-parser": "~1.19.0",
    "chalk": "~2.4.2",
    "codelyzer": "~5.1.2",
    "cookie-parser": "~1.4.4",
    "cross-env": "~6.0.2",
    "enhanced-resolve": "4.1.0",
    "express": "~4.17.1",
    "fs-extra": "~8.1.0",
    "isomorphic-fetch": "~2.2.1",
    "jasmine-core": "~3.5.0",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~4.3.0",
    "karma-chrome-launcher": "~3.1.0",
    "karma-cli": "~2.0.0",
    "karma-coverage-istanbul-reporter": "~2.1.0",
    "karma-jasmine": "~2.0.1",
    "karma-jasmine-html-reporter": "~1.4.2",
    "npm-run-all": "~4.1.5",
    "protractor": "~5.4.2",
    "ts-loader": "~6.2.0",
    "ts-node": "~8.4.1",
    "tslint": "~5.20.0",
    "typescript": "~3.5.0",
    "webpack-cli": "~3.3.9"
  }

It seems to create the app with all the latest versions of everything. This is a problem as the company I work for uses node v8.10.0 so when trying to run this app it does not work.

I want to be able to create a new JSS app with the older version, any help appreciated

Juan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.