1

Sitecore 8.2 update 5 on Azure App Services. Anyone knows what could be the reason

<pipelines>         
    <indexing.getDependencies>
        <processor type="Custom.Infrastructure.Pipelines.GetLocalDatasourceDependencies, Custom.Assembly" />
        <!-- When indexing an item that is used as a datasource, make sure that all the items that reference the datasource in their presentation details gets re-indexed as well. -->
        <processor type="Sitecore.ContentSearch.Pipelines.GetDependencies.GetDatasourceDependencies, Sitecore.ContentSearch"/>
    </indexing.getDependencies>
</pipelines>

Error message:

Exception: System.NullReferenceException
Message: Object reference not set to an instance of an object.
Source: Sitecore.ContentSearch
   at Sitecore.ContentSearch.Pipelines.GetDependencies.GetDatasourceDependencies.<>c.<GetSourceUris>b__1_0(ItemLink l)
   at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
   at System.Linq.Enumerable.WhereEnumerableIterator`1.MoveNext()
   at System.Linq.Enumerable.<DistinctIterator>d__64`1.MoveNext()
   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
   at System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection)
   at Sitecore.ContentSearch.Pipelines.GetDependencies.GetDatasourceDependencies.Process(GetDependenciesArgs context)
   at (Object , Object[] )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
   at Sitecore.Abstractions.CorePipelineWrapper.Run(String pipelineName, PipelineArgs args)
   at Sitecore.ContentSearch.Pipelines.GetDependencies.GetDependenciesPipeline.GetIndexingDependencies(IIndexable indexable)
   at Sitecore.ContentSearch.Crawler`1.UpdateDependents(IProviderUpdateContext context, T indexable)
   at Sitecore.ContentSearch.SitecoreItemCrawler.DoUpdate(IProviderUpdateContext context, SitecoreIndexableItem indexable, IndexEntryOperationContext operationContext)
   at Sitecore.ContentSearch.SitecoreItemCrawler.Update(IProviderUpdateContext context, IIndexableUniqueId indexableUniqueId, IndexEntryOperationContext operationContext, IndexingOptions indexingOptions)
   at Sitecore.ContentSearch.AbstractSearchIndex.<>c__DisplayClass94_2.<PerformUpdate>b__0(IndexableInfo info, ParallelLoopState parallelLoopState)
   at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1()
   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)
   at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object <p0>)
1

GetDatasourceDependencies checks for all the dependencies.

In the background it uses LinkDatabase to get all the referrers and referred items.

If there is an item link in the LinkDatabase but the items from the link are no longer in database, it may result in null reference exception.

Solution: rebuild the link database.

| improve this answer | |
  • thanks marek, I had triggered rebuilding link db , but the process errored out – Abhay Dhar Sep 16 at 16:01
  • What is the error? I think that's another issue that you have to fix first. Maybe post another question about the exception while rebuilding link database if you cannot fix it on your own? – Marek Musielak Sep 16 at 18:31
  • Yes , trying to check out what is the error while rebuilding links , but on azure app services , difficult to get the actual error – Abhay Dhar Sep 16 at 18:37
  • Maybe try running "Clean up databases" first? – Marek Musielak Sep 17 at 6:24
  • Thanks , truncated core db links table there were 5L records, but app services are excruciatingly slow – Abhay Dhar Sep 17 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.