I have installed Sitecore Publishing Service 4.3.0 and its counterpart module (Sitecore Publishing Module rev. r00568.2697.zip) into a new clean Sitecore 10.0 XP0 by following the official manual. There were no problems while following it, all the steps seemed logical and worked as expected.

The problem: unless I manually run the executable (Sitecore.Framework.Publishing.Host.exe) - no publishing happens. Once I manually run it - it loads in command prompt with default big "Publish" console-art and the message to press Ctrl+C to shut down. While this command prompt is open - publishing works well and items appear on the web from master as they normally should do.

However, when I close this console window, no more publishing happens and I am getting the errors: The publishing service is not running. Please contact your system administrator.

What is interesting, the process Sitecore.Framework.Publishing.Host.exe is running (as it should do) after I trigger a testing request (to http://publishing.service/api/publishing/operations/status getting expected {"status":0} response)

When I then manually run executable, I get two identical processes with one difference that manual runs under my user credentials rather than AppPoolIdentity, which is understandable. Also, one of processes' command line is wrapped with brackets, the other isn't, but these both are acceptable - some processes do have them, others don't. Just in case, I even tried giving app pool Local System account to test if that may be a case of some permissions missing, but the experiment ended that same: enter image description here

As I mentioned. when I manually run Sitecore.Framework.Publishing.Host.exe executable (the above process) - publishing works well, the item appears at Publishing Target (web database) and the task is also reflected at Publishing Dashboard.

Logs: look clear - no errors. At least nothing looking criminal to my eyes.

Web.config file within publishing service points to the correct executable. I also tried "debloating" the config as prompted at the bottom of this blog post, but debloating also did not fix the problem

Service installation steps, as I did it:

  1. Created a folder and extracted everything into
  2. Provided connection strings to master, web, and core databases by .\Sitecore.Framework.Publishing.Host.exe configuration setconnectionstring core <value>
  3. .\Sitecore.Framework.Publishing.Host.exe configuration set Sitecore:Publishing:InstanceName --value <PS_INSTANCENAME>
  4. \Sitecore.Framework.Publishing.Host.exe schema upgrade --force
  5. .\Sitecore.Framework.Publishing.Host.exe IIS install --hosts --force

As for the counterpart module, I have made a config patch where referenced PublishingService.UrlRoot as described in the manual.

Literary, lost my head out of this issue. Am I missing something important?

  • Did you set the app pool to unmanaged in IIS? Since you are running the exe out of the same IIS folder, I have to imagine your connection strings are just fine.
    – Chris Auer
    Sep 22, 2020 at 17:49
  • Sure that was my first assumption, and the automated installation by .\Sitecore.Framework.Publishing.Host.exe iis install --hosts --force did that for me (I double checked for it). Sep 22, 2020 at 17:58
  • Did you ever get this fixed? Same issue here
    – geedubb
    Apr 27, 2021 at 13:53
  • Martin, please can you add the resolutions of this issue?
    – Jitendra
    Sep 5, 2021 at 7:56
  • using Sitecore Publishing Service 7.0 and did all the steps above and created a patch file and there was no issues <?xml version="1.0" encoding="utf-8"?> <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/"> <sitecore> <settings> <setting name="PublishingService.UrlRoot" value="http://sitecore.publishing/" /> </settings> </sitecore> </configuration>
    – Aaron
    Feb 13 at 20:53

1 Answer 1


I faced the similar issue with Sitecore 10.1 and Sitecore Publishing Service 5.0.0.

enter image description here

I started the publishing service host service by using following command:

enter image description here


After running this command, I am not seeing this error and able to publish the items from CMS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.