0

A page on the site contains rich text, part of which is a series of links to PDF documents the user can download. Clicking on these, however, results in a 404 error.

I've tried several RTE editing techniques to create the links: in particular, I've tried using both the Media Items and Search tabs in the Insert Link dialog to create the links, since they create different variations of internal links:

https://domain.name/-/media/Files/HCE/Documents/file-name-A.ashx
https://domain.name/-/media/Files/HCE/Documents/file-name-B.ashx?la=en&hash=407C1742E64B43FBEAD44C37277859973BF2B581486B09C905CC0570386324D3

I've also tried using the html editors to hack the links thus generated, e.g., by adding the "download" attribute to the anchor tags. None of these measures have been successful. (The "download" attribute did create a download link successfully, but the stub file it downloaded was invalid.)

I need to make this work from within the Rich Text Editor as it's important that our content contributors be able to maintain this themselves. Is there anything particularly evident from the above we might be doing wrong?

4
  • Use the "Insert Sitecore Link" and then select the media items tab and select the file. Make sure that the media file is published too. Oct 20 '20 at 8:56
  • My guess would be that your media items are not published.
    – Richard Seal
    Oct 20 '20 at 14:13
  • It doesn't seem to be an issue of publishing status of the media item. (I find it hard to ascertain whether the item is in fact published, but republishing it to make sure doesn't seem to make a difference.) Oct 20 '20 at 15:18
  • Another discovery which might be relevant: the links work fine when invoked on the CMS server. It's just on delivery servers that they get lost. Oct 20 '20 at 15:43
0

The problem ended up being with the media items after all. They were created with File Path specifications; I don't know how or why that was done (I've never seen one before), but no files existed at those paths on the CD servers, resulting in the 404 errors. My resolution, at least temporarily, was to copy these files from the CMS server to the CD servers.

2
  • Someone selected the "Upload as File" option, it's a checkbox on the "Advanced Upload" dialog.
    – jammykam
    Oct 22 '20 at 20:54
  • @jammykam Helpful to know! Thanks! Oct 23 '20 at 22:03
0

Sometimes this error may occur due to less space in Local Drive C or D. Check the space in Local Drive where the site configuration is present. Once Freed up some space in Local Drive, the media file will load correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.