8

I'm getting below error when trying to build package using Sitecore Rocks. While building package it takes some time so the connection is getting timed out.

The request channel timed out while waiting for a reply after 00:00:59.9909995. Increase the timeout value passed to the request or increase the SendTimeout value on the Binding. localhost/.../service2.asmx has exceeded the allotted timeout of 00:00:59:998000

I have tried updating compilation to debug="true" and also tried updating timeout attributes on SitecoreApplicationCenter under <system.serviceModel> thinking it will work but still I get timeout.

2
  • Are you using HTTPS on the site you're connecting to? If there's an HTTP->HTTPS redirect set up, Sitecore Rocks may time out because of that. Disable the redirect in your development environment and the issue will be solved. Commented Nov 18, 2016 at 11:53
  • 1
    Site is on local system only and it is HTTP. Other features work fine of Rocks. Only Build package takes time because package defined by me has lots of items.
    – Harsh Baid
    Commented Nov 18, 2016 at 12:37

2 Answers 2

6

You can find the connection xml under

C:\Users\Administrator\AppData\Local\Sitecore\Sitecore.Rocks.VisualStudio\Connections

Open the xml file and edit the timeout attributes as needed.

enter image description here

<binding hostName="sc81" useWindowsAuth="false"
userName="sitecore\admin" password="b21d95ba8b8afb0d" 
dataService="Hard Rock Web Service"
webRootPath="E:\SC81\Website"     
description="" isRemoteSitecore="false" 
automaticallyUpdate="true" isHidden="false"
hostNameComparisonMode="StrongWildcard" 
receiveTimeout="00:10:00" 
sendTimeout="00:01:00" 
openTimeout="00:01:00" 
closeTimeout="00:01:00" 
maxReceivedMessageSize="16777216" maxBufferSize="16777216" maxBufferPoolSize="524288" maxStringContentLength="16777216" transferMode="Buffered" messageEncoding="Text" textEncoding="utf-8" bypassProxyOnLocal="false" useDefaultWebProxy="true" proxyAddress="" />
1

You can lookup the configuration here: C:\Users\USERNAME\AppData\Local\Sitecore\Sitecore.Rocks\Connections

1
  • Please include more detailed instructions on increasing the timeout setting. Commented Nov 18, 2016 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.