I've got a new install of Sitecore 8.2 with the SXA add-on configured, and I'm trying to add a map component to my page. When I add it, I get the following error: Google Maps Error

I looked at the console, and it is complaining about not having an API key set. I went ahead and got an API key from Google, but now I can't figure out where to put it so that SXA/Sitecore will use it while it's generating the map.

How do I get the map to show up correctly in SXA?

  • Under settings there is an item called Map Provider. Set the key there. Nov 18, 2016 at 22:59
  • 1
    You may also find this helpful. michaellwest.blogspot.com/2016/10/… Nov 18, 2016 at 23:01
  • That link to the blog post is very helpful. It fills in the gaps for me quite nicely. Thank you! Nov 18, 2016 at 23:06
  • Perhaps you can answer your question with the steps you used to get it to work and some pretty pictures. Nov 19, 2016 at 0:05

2 Answers 2


The first thing that you need to do is to go into the Maps Provider for your website. You can find that under the Settings node in the Content Editor.

Where the maps provider settings live

When you click on the Maps Provider node, you will see a screen that looks something like this: Where you enter your maps key

You just need to enter your Google Maps API Key into that box, save the item, and you'll instantly be able to render the maps.


Google is enforcing the use of API keys, effective June 11th 2018. Keyless usage will result in a degraded experience, or an error. See more details here.

This means that you not only have to specify Authorization Key for Maps Provider as Keith correctly mentioned in his Answer but you also need to enable Google Maps APIs for your account and that Authorization Key. Without this SXA Map Component won't work at all.

These are the APIs that you need to enable for your account / Authorization Key: enter image description here

You should have same list of APIs as are in picture under "In use APIs". Obviously you can have more if you are using more services from Google but for Map component to work this is minimum.

More details in this blog post: https://tothecore.sk/2018/09/07/sitecore-sxa-set-google-maps-for-map-component-with-latest-pricing-changes/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.