0

I am using sitecore 9.3 and facing an issue with xconnect when using identifyas in the code to identify the user using the email i got the below exception

Exception: Sitecore.Analytics.DataAccess.XdbUnavailableException Message: xDB unavailable Source: Sitecore.Analytics.XConnect at Sitecore.Analytics.XConnect.DataAccess.XConnectDataAdapterProvider.ExecuteWithExceptionHandling[T](Func2 func) at Sitecore.Analytics.XConnect.Diagnostics.PerformanceCounters.OperationPerformanceMonitorExtensions.<>c__DisplayClass1_0.<Monitor>b__0() at Sitecore.Analytics.XConnect.Diagnostics.PerformanceCounters.OperationPerformanceMonitorExtensions.Monitor[T](OperationPerformanceMonitorBase monitor, Func1 operation) at Sitecore.Analytics.Tracking.StandardSession.IdentifyAs(String source, String knownIdentifier) at Authentication.Pipelines.CookieAuthentication.SignedIn.UpdateUserProfile.Process(SignedInArgs args)

Nested Exception

Exception: Sitecore.XConnect.XdbCollectionUnavailableException Message: { "Message": "Operation failed: The lock time has expired." } Source: Sitecore.XConnect.Client at Sitecore.XConnect.Client.XConnectSynchronousExtensions.SuspendContextLock(Func1 taskFactory) at Sitecore.Analytics.XConnect.DataAccess.XConnectDataAdapterProvider.<>c__DisplayClass35_0.<ExecuteWithExceptionHandling>b__0(IXdbContext c) at Sitecore.Analytics.XConnect.DataAccess.XConnectDataAdapterProvider.ExecuteWithExceptionHandling[T](Func2 func)

1
  • It sounds like you have SQL performance issues.
    – Chris Auer
    Nov 12 '20 at 13:55
0

The issue was related to the time of the SQL server was not correct and was different from that on CD\CM. Issue is fixed after adjusting the time on SQL server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.