1

I'm having issues building a TDS for project. The url and IIS 100% point to the same place which makes me baffled. I've tried being on Admin, Changing permissions, doing different versions and basically everything I could think of but for one reason or another it doesn't seem to register they are the same place. The full error is TDS connection failed, please check that Sitecore Web Url and Sitecore Deploy Folder point to the same location. Verify you settings with the settings in IIS.

0

You can try to add TdsGlobal.config file to your solution.

    ?xml version="1.0" encoding="utf-8"?>
<Project ToolsVersion="3.5" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">  
  <PropertyGroup>
    <AssemblyStatus>Exclude</AssemblyStatus>
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)' == 'Debug' ">
    <SitecoreWebUrl>[sitecore url here]</SitecoreWebUrl>
    <SitecoreDeployFolder>[sitecore website folder path here]</SitecoreDeployFolder>
    <RecursiveDeployAction>SitecoreRecycle</RecursiveDeployAction>
    <InstallSitecoreConnector>True</InstallSitecoreConnector>
    <DisableFileDeployment>False</DisableFileDeployment>
    <GeneratePackage>False</GeneratePackage>
    <SitecoreAccessGuid>[guid here]</SitecoreAccessGuid>
  </PropertyGroup>

</Project>

I think TDS looks at SitecoreDeployFolder in your case, that needs to match the IIS setup. These settings can be configured also on TDS project level, when you right click on project, choose properties and Build section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.