0

I have Sitecore 9.3 with Azure PAAS and are using Azure search.

I added one 'shared' field to the media templates of the checkbox type with name IsOptimized. I added the following entry to the config. I just want to filter data on the basis of it.

<field fieldName="isoptimized"       cloudFieldName="isoptimized_b"    searchable="NO"   retrievable="YES"  facetable="YES"  filterable="YES"  sortable="YES"  boost="1f" type="System.Boolean"  settingType="Sitecore.ContentSearch.Azure.CloudSearchFieldConfiguration, Sitecore.ContentSearch.Azure" />

I also made an entry for the same under Fields under the index. I indexed the item when the checkbox is selected and when the checkbox is not selected. But in both the scenarios, I am getting the item in the Azure search but not the field with the correct value.

We do have certain fields like created by indexed in it for the item.

Am I missing something silly?

Edit 1:

Adding the snapshot from Azure search where I have mapped the field.

enter image description here

Presently, even if the checkbox is selected, I am getting null for that item. I am just checking the item by its id and checking all the fields on the Azure portal itself.

3
0

I was able to get the field indexed. I was missing the entry in the following section of Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.