I have tried to upgrade 8.0 to 8.1 but its giving me an error: "The layout for the requested document was not found". I have rechecked all the steps mentioned in the upgrade guide, and everything is correct, but I'm still getting the error. How do I solve this?

  • Have you checked the logs for all errors? Can you place those in your question to help others diagnose? Also, what are you doing when you receive this error? Can you login to Sitecore? etc. You will need to add some more details so others can help. Nov 21, 2016 at 13:14

1 Answer 1


We had the same error after upgrading from 8.0 to 8.1. All you should have to do is select a layout in the home item. For some reason that gets lost with an upgrade.

  • Thanks for your responce, the layout was already set but still not working.. In logs, i got error is : "Sitecore has no necessary permissions for reading/creating counters".. please help me on this.. Nov 21, 2016 at 12:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.