I am trying to set up Sitecore 9.3 XP0 locally in a VM using SIA and it is failing at Step 67 of 92 with an error failed to start the marketing Automation Engine Service.

 System.InvalidOperationException: This configuration has not been initialized. Please call the initialize method before using it.
    at Sitecore.XConnect.Client.XConnectClientConfiguration.CheckInitialized()
    at Sitecore.XConnect.Client.XConnectClientConfiguration.get_CurrentModel()
    at Microsoft.Extensions.DependencyInjection.ServiceLookup.CallSiteRuntimeResolver.VisitScoped(ScopedCallSite scopedCallSite, ServiceProviderEngineScope scope)
    at Microsoft.Extensions.DependencyInjection.ServiceLookup.DynamicServiceProviderEngine.<>c__DisplayClass1_0.<RealizeService>b__0(ServiceProviderEngineScope scope)
    at Microsoft.Extensions.DependencyInjection.ActivatorUtilities.ConstructorMatcher.CreateInstance(IServiceProvider provider)*

I did try to start the service manually and getting the same error. When I checked the XConnect logs I found the below issue,

*Error initializing XConnect client.
System.AggregateException: One or more errors occurred. ---> Sitecore.XConnect.XdbCollectionUnavailableException: An error occurred while sending the request. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
--- End of inner exception stack trace ---

My SOLR is running fine and the license is not having any issues as the same license seem to be working well in another developer's local machine.

There are many such issues that had been resolved to check for the non-self signed certs and moving to a different destination which didn't work for me, unfortunately.

Any help or suggestions would be greatly appreciated.


9 Answers 9


I had similar issue when installing. I followed the below steps before installing or running the setup exe.

Check for any non-self-signed certificates, execute below PowerShell script to find out:

Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject}

enter image description here

If you found any result item from the above PowerShell script then execute the below PowerShell command to move these non-self-signed certificates into the Intermediate Certification Authorities store :

Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-Item -Destination Cert:\LocalMachine\CA

enter image description here

After doing this, close the PowerShell window and reopen it to execute your Sitecore installation script.

  • 1
    This solved the issue for me. Thanks.
    – D J
    Jun 6, 2023 at 10:10

Make sure ASP.NET 4.7 is enabled for development in IIS server in Windows features. All the below highlighted features should be checked. enter image description here

For more details, you can check out this post: https://www.linkedin.com/pulse/sitecore-93-local-installation-raman-gupta/

  • The ASP.NET is enabled in the machine, I am working on a Windows Server 2016 so ASP.NET 4.7 or 4.8 is not getting listed , but I have downloaded and installed them in the machine. I did verify in the Registry for the Release version under 'Net Framework' it says 4.7 version is installed and enabled - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    – Deepak
    Jan 5, 2021 at 17:51

In our case it was also a certificate issue. Add permissions for IUSR, IIS_IUSRS & NETWORK_SERVICE , SERVICE by right clicking on certificate in certificates console and selecting manage private keys. You can also try to start Marketing Automotion manually from command line. Navigate to your xconnect instance /app_data/jobs/continous/AutomationEngine and from cmd/powershell run maengine.exe. This might give you more precise error. Also check if there is no Marketing Automation service running with same name.

  • "...by right clicking on certificate in certificates console" Which certificate?
    – T H
    Jun 3, 2022 at 15:12
  • @T H .xconnect certificate.
    – Kamil C
    Jun 3, 2022 at 16:51

We had a similar problem while installing Sitecore 10.2 installation. I hope that we have to find the actual cause of this issue before trying solutions. To identify the cause:

  • Check the IIS logs for the xConnect application ID. How to check the IIS logs with the application ID. Please refer to below path: In our case, 20 is xConnect app id: enter image description here

  • It will provide you the actual cause of the issue. In our case, below is the error. enter image description here

  • Based on the error message, we can come to know that issue with certificates. So we ran the below steps as we gone through some blogs (Thanks for all bloggers around the world)

  • To find non self signed certificates:

  • Check for any non-self-signed certificates, execute below PowerShell script to find out:

    Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject}

  • To move them to Intermediate certification authorities store:

    Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-Item -Destination Cert:\LocalMachine\CA

  • After executed above steps, we restarted IIS and ran UnInstall SIF script to uninstall all previous installations and executed Install SIF script once again. Issue resolved.


Sometimes, if you have tried the installation script more than once, you can have some undesired behavior. Like some said before, you are possibly trying to go forward with the wrong certificates. Also, some of these services were actually created on previous installation attempts.

Here is what I think should help you get through.

Clean your workspace

  • Remove your databases that are related to the installation if exists.
  • Remove your certificates (using certlm -> you can type in your windows search bar "cert" and then you should be able to pick "Manage computer Certificate".
    • On the left sidebar, Click on Personal > Certificates.
      • Remove your installation-related certificates
        • nameOfYourInstallation.identityserver
        • nameOfYourInstallation.sc
        • nameOfYourInstallation.xconnect
  • Open your Windows Services Manager (you can type in your windows search bar "services" and select the services app)
    • You should be able to see those services :
      • Sitecore Marketing Automation Engine - nameOfYourInstallation(might be one of your previous install)
      • Sitecore Processing Engine - nameOfYourInstallation
      • Sitecore XConnect Search Indexer - nameOfYourInstallation.
        • Write those down. Keep your service app open.
    • Using NSSM (probably installed already from some of your previous installed, if not, can use chocolatey ( https://chocolatey.org/packages/NSSM ) remove those services.
    • in a cmd : nssm remove serviceName
      • Note that you can remove them by right clicking etc. I just prefer the nssm way.
  • When its done, restart your computer (some services and in a state of removal, that needs a restart to be completely removed)
  • Try to install with SIA again.
  • 1
    Thanks for the inputs, Yes, I Cleared all old instances, certificates, DBs and removed all services with NSSM also restarted the machine but still the installation is failing.
    – Deepak
    Jan 6, 2021 at 15:23
  • Have you also previously removed anything that was created from previous attemps in your inetpub/wwroot/yourInstance ? And just to be sure, is your sitecore license still valid (not expired for example) ? Also, there are some other interesting q and a here : community.sitecore.net/developers/f/5/t/10025 Jan 6, 2021 at 19:20
  • I have tried what is recommended in that forum, to no avail. as per the license goes the install had worked well without any issues with the same license in another machine So I don't think that could be the issue.
    – Deepak
    Jan 6, 2021 at 19:59

We had similar issues installing Sitecore 9.3 XP on virtual machines running 2016. The only solution that worked for us is updating the user permission on inetpub folder.

Steps we followed to fix the issue

  1. Removed all the databases from SQL server for the instance created
  2. Delete the folders created in inetpub folder
  3. removed all the services (by stopping some of the background services running)
  4. Update the permissions on inetpub folder to give full control for all users (this is temp step, please revert it back once installation is successful)
  5. Install Sitecore 9.3 XP0 again

This should install without any issues.

Make sure you change the permissions after installation is done.


I had faced the same issue during the installation of Sitecore 9.3. It was because the certificate already exists with the same Sitecore instance name in my machine.

I have followed the below steps to get rid of this:

  1. Removed the certificates from my machine with the same instance name
  2. Removed Services
  3. Removed the Sitecore instance from the inetpub directory, IIS
  4. Removed Solr Indexes
  5. Removed Database from SQL server

Refer blog post for more details about, how I debugged the issue and solution: Sitecore Installation Error: Failed to Start Service 'Sitecore Marketing Automation Engine'


After using the other fixes mentioned in here, my install continued to fail because I didn't have MSSQL Server 2016 SP1 installed and configured properly. I figured that out by looking in the Event Viewer and noticing SQL exceptions.


I had a similar issue with Sitecore 9.3 installation. I double checked all certificates and thumbprints and they were correct.

Eventually I found that my antivirus software was replacing xConnect SSL certificate behind the scenes. As soon as I disabled this feature in antivirus, Marketing Automation Engine started without errors and Sitecore installation completed successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.