1

Has anyone faces this error while installing sitecore using the GUI interface?

Security error.
Security error.
Security error.
Security error.
                      ************************************
                           Sitecore Install Framework
                                 Version - 2.2.0
                      ************************************


WorkingDirectory       : C:\Projects\jss-app
WhatIf                 : False
Verbose                : SilentlyContinue
Configuration          : C:\Users\username\Downloads\Sitecore_9.3.0_rev._003498_(Setup_XP0_Developer_Workstation_
                         rev.1.1.1-r4)\Prerequisites.json
Debug                  : SilentlyContinue
AutoRegisterExtensions : False
WarningAction          : Continue
ErrorAction            : Stop
InformationAction      : Continue





[-- DownloadVisualC++2015x86 [Skipped] : DownloadFile ------------------------]

[--------- InstallC++2015x86 [Skipped] : StartProcess ------------------------]

[-- DownloadVisualC++2015x64 [Skipped] : DownloadFile ------------------------]

[--------- InstallC++2015x64 [Skipped] : StartProcess ------------------------]

[----------- SQLServerModule [Skipped] : InstallModule -----------------------]

[--------------------- WindowsFeatures : EnableWindowsOptionalFeature --------]

[ DownloadWebPlatformInstaller [Skipped] : DownloadFile ------------------------]

[ InstallWebPlatformInstaller [Skipped] : StartProcess ------------------------]
Unable to parse [variable('WebDeploy.Version.Compare')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [InvokeExpression(Command:variable('WebDeploy.Version.Command'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [concat('[system.version]"',variable('WebDeploy.Null.Version'),'" -ge [system.version]"',variable('WebDeploy.Minimum.Version'),'"')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [if(variable('WebDeploy.Version'),variable('WebDeploy.Version'),'0.0')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [SelectObject(InputObject:variable('WebDeploy.Package'),ExpandProperty:'Version')] - Exception calling "InvokeWithContext" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Property "Version" cannot be found."""""
[TIME] 00:00:11
Unable to parse [variable('WebDeploy.Version.Compare')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [InvokeExpression(Command:variable('WebDeploy.Version.Command'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [concat('[system.version]"',variable('WebDeploy.Null.Version'),'" -ge [system.version]"',variable('WebDeploy.Minimum.Version'),'"')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [if(variable('WebDeploy.Version'),variable('WebDeploy.Version'),'0.0')] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [SelectObject(InputObject:variable('WebDeploy.Package'),ExpandProperty:'Version')] - Exception calling "InvokeWithContext" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Property "Version" cannot be found."""""

I'm running the sitecore installation exe as an admin user.

0

There are issue related to Webdeploy download from config prerequisites.json, will suggest to download manually Webdeploy 3.6 version https://www.microsoft.com/en-us/download/details.aspx?id=43717 And then try again with exe.

2
  • Thank you Pradeep. I did try this but I'm still seeing the same error. Any idea why the initial Security Errors would be showing up? I'm running the installer with admin privileges. – Manoj Sreekumar Dec 28 '20 at 14:38
  • Please ensure you have full administrator rights from IT team. – Pradeep Gupta Dec 28 '20 at 14:42
0

Couple of things to try:

- If you have never installed Sitecore 9 before, you will probably want to execute

Set-ExecutionPolicy -Scope CurrentUser Unrestricted

  • Enable Contained Database Authentication if not yet: In order to enable contained databases on SQL Server, run this SQL script through SQL Server Management Studio:

EXEC sp_configure ‘contained’, 1; RECONFIGURE;

  • Make sure all pre-requisites are installed properly.
  • Check you've local admin rights to the machine and give below access to wwwroot folder

a. Network Service -> Full Access
b. IIS_IUSERS -> Full Access
c. LOCAL SERVICE -> Full access

Refer to this post for more details: https://www.linkedin.com/pulse/sitecore-93-local-installation-raman-gupta/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.