2

I have tried to solve this problem, but I'm putting question here to understand this Cloned Item problem properly and fix it in best possible way out.

Alright so I have few Clone Items in this website out of which this one culprit is not showing Original Item's field value in Sitecore Content Editor.

On Clone Item, I have tried to workaround this problem by doing 'remove version' and then doing 'add version' still its takes (restores) the previous values somehow. My thinking was if I do 'remove version' on Clone Item it should clear the overridden values on Clone Item for particular Language version.

From Ribbon menu, when I go to "Versions > Reset" it doesn't shows [original value] next to concerned field names.

From Ribbon menu "Versions > Reset"

P.S: This Original Item and Clone Item both exists in multiple languages, I'm trying to restore field value inheritance within particular language version only. It seems to me for other languages field value inheritance is working fine.

Since remove version is not removing the overridden values from Clone Item as I have observed the value come back as soon as I add new version on Clone Item.

So my questions in this relation are:

  1. Why does Remove version doesn't clear the overridden values from Clone Item per Language version?

  2. How I can clean overridden values in Clone Item within Language version without doing Reset on fields and If I have to go for Reset command, will that affect other Language versions of Cloned Item?

Update 1

I have observed that after I remove version on Clone Item's Language version, nothing is returned in SQL in UnversionedFields and VersionedFields for this Item/per Field/per Language. However when I execute add version somehow Sitecore brings back the data in these tables.

Please can anyone tell why its like this?

I'm using Sitecore 7.5 update-2

  • what is the sitecore version your are using ? also, that item language version that you tried removing, you are removing all the versions of that language ?? – scFootsteps Nov 22 '16 at 7:45
  • Sitecore 7.5 update-2 – Harsh Baid Nov 22 '16 at 8:40
  • I cannot reproduce the issue you're having with values being restored after re-adding a new version. Is there anything special about your setup? Also, could you create a package containing the original item and the problematic clone, upload the package somewhere and attach a link here? – Dmytro Shevchenko Dec 1 '16 at 8:45
  • I don't have the item package now since I have resolved the problem by using Reset command workaround but from you response what I understood is item got Uncloned in specific language version only but other thing is after I click on Reset the dialog box that comes, was showing [Original Value] on other fields except the fields with issues. – Harsh Baid Dec 1 '16 at 8:49
1

The most likely reason for this is that the clone item is not a clone anymore. It could have been uncloned, which would lead to the behavior you're seeing.

A clone item can be uncloned:

  • If someone has used the "Unclone" feature on the "Configure" ribbon tab;
  • If someone has removed a version of the original item. A quote from Sitecore documentation:

    Removing a version of the original item that has clones

    All the clone versions that are linked to that specific version of the original item are uncloned.

    This means that these versions of the clone are turned into regular items that no longer inherit any values from the original item.

  • My core question is Why does 'Remove version' doesn't clear the overridden values from Clone Item per Language version? since as soon as I do Add version previous field values come back supernaturally.. – Harsh Baid Nov 30 '16 at 20:00
  • @HarshBaid I thought your core question was "How I can clean overridden values in Clone Items within Language version?" And the answer to that question is: you cannot, since your clone has been uncloned. In regard to the other question, it must be a defect, but getting an exact answer to that question won't help you with your business-driven problem. – Dmytro Shevchenko Nov 30 '16 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.