0

Running our Sitecore JSS site regularly produces following (cryptic) error:

Error Rendering Sitecore.JavaScriptServices.ViewEngine.Presentation.JsLayoutRenderer: Empty strings are not allowed. Parameter name: id
   at Sitecore.Diagnostics.Assert.ArgumentNotNullOrEmpty(String argument, String argumentName)
   at Sitecore.JavaScriptServices.ViewEngine.Node.NodeRenderEngineOptionsResolver.ResolveForId(String id)
   at Sitecore.JavaScriptServices.ViewEngine.Node.NodeRenderEngineFactory.<>c__DisplayClass5_0.b__1()
   at System.Lazy`1.CreateValue()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Lazy`1.get_Value()
   at Sitecore.JavaScriptServices.ViewEngine.Presentation.JssRenderer.ResolveRenderEngine()
   at Sitecore.JavaScriptServices.ViewEngine.Presentation.JssRenderer.Render(TextWriter writer)
   at Sitecore.Mvc.Pipelines.Response.RenderRendering.ExecuteRenderer.Render(Renderer renderer, TextWriter writer, RenderRenderingArgs args)

It appears rather randomly, without a clear pattern to reproduce it. Recycling the IIS application pool usually resolves the problem. But since it appears at least a few times per day, it's not a sustainable solution.

The Sitecore instance we're using has multiple tenants, some of which are JSS and some of which are SXA.

Has anyone seen this before?

1
  • 1
    This one will likely take some digging and potentially access to product source. I do not see any known issues related to this. I'd recommend contacting Sitecore Support. – nickwesselman Feb 11 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.