I have problems with login using the default admin user. it wont let me login using /sitecore/admin/login.aspx

If I login to the launchpad, I just get this

Error Page

It worked as expected after the clean install.

But now the customer has changed the hostname, and the admin user is no longer working?

The user is still in core db, with isApproved = true, isLockedOut = false, IsAnonymous = false. The password is still b

What am i missing?

  • 2
    What do you mean with "the customer has changed the hostname"? Can you identify all changes that were made? – Gatogordo Nov 22 '16 at 10:58
  • It turns out, that the authentication mode was set to windows, and not none as default, in the web.config, After changing it back, it all worked again. It would be nice to know if the IIS can modify this setting itself or? – JimmieR Nov 24 '16 at 6:28

Verify that your authentication mode is configured properly :) After helping him I can verify that the authentication provider was set to windwos and not Forms, after switching back to Forms it worked againg

  • Sorry for the late reply.. It turns out, that the authentication mode was set to windows in the web.config – JimmieR Nov 24 '16 at 6:21

I doubt this has anything to do with your admin user.

You say the host name has been changed. Likely you have a <site> definition for your site that sits in a wrong place in the order of sites that serve up Sitecore.

    <site name="shell" virtualFolder="/sitecore/shell" physicalFolder="/sitecore/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" loginPage="/sitecore/login" content="master" contentStartItem="/Home" enableWorkflow="true" enableTracking="false" analyticsDefinitions="content" xmlControlPage="/sitecore/shell/default.aspx" browserTitle="Sitecore" htmlCacheSize="10MB" registryCacheSize="15MB" viewStateCacheSize="1MB" xslCacheSize="25MB" disableBrowserCaching="true" />
    <site name="login" virtualFolder="/sitecore/login" physicalFolder="/sitecore/login" enableTracking="false" database="core" domain="sitecore" disableXmlControls="true" />
    <site name="admin" virtualFolder="/sitecore/admin" physicalFolder="/sitecore/admin" enableTracking="false" enableWorkflow="true" domain="sitecore" loginPage="/sitecore/admin/login.aspx" />
    <site name="service" enableTracking="true" virtualFolder="/sitecore/service" physicalFolder="/sitecore/service" />
    <site name="modules_shell" virtualFolder="/sitecore modules/shell" physicalFolder="/sitecore modules/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" content="master" enableTracking="false" enableWorkflow="true" />
    <site name="modules_website" virtualFolder="/sitecore modules/web" physicalFolder="/sitecore modules/web" rootPath="/sitecore/content" startItem="/home" language="en" database="web" domain="extranet" allowDebug="true" cacheHtml="true" />
    <site name="website" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/home" database="web" domain="extranet" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB" />
    <site name="scheduler" enableTracking="false" domain="sitecore" />
    <site name="system" enableTracking="false" domain="sitecore" />
    <site name="publisher" domain="sitecore" enableTracking="false" enableWorkflow="true" />

You need to make sure, your custom site definition (the one you just changed the host name for) comes after the Sitecore sites ("shell", "login", "admin", "service", "modules_shell" and "modules_website"). Otherwise your site will try to process the login request and ultimately fail.

How have you changed your site definitions after the working vanilla install? Normal procedure is to patch in new sites just before the "website" site definition.

  <site name="custom" patch:before="site[@name='website']"
  • Hi Mark. The site definition is placed exactly like yours after the sitecore sites. I only have one custom sitedefinition, but its not called website though. The only thing that has changed, is the targetHostName. The site is running fine – JimmieR Nov 22 '16 at 11:14
  • Then we need more information, as @gatogordo points out. – Mark Cassidy Nov 22 '16 at 13:46

Most probably with the host name the wwwroot folder path would have also changed and some of the files in the "sitecore" folder would be missing.

Try replacing the sitecore folder (C:\inetpub\wwwroot\yourSitecore\Website\sitecore) with the one working properly or from the installable archives. If this doesn't work try verifying the files in App_Config folder.

  • I'm sorry but I don't see any relation with the topic nor does it make much sense. Changing a binding in IIS doesn't have much to do with the physical path of the application. Some config is messed up, I agree. – Dražen Janjiček Nov 22 '16 at 18:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.