0

New to JSS. Trying to use Sitecore Forms + JSS for the first time, I followed JSS documentation, creating a form in Sitecore; when I run jss deploy component Form --allowedplaceholders jss-main, I get error:

Manifest has been generated and written to C:\...\AppData\Local\Temp\tmp-52900G0A3kyGFGNy1\manifest\tempManifest.json/sitecore-import.json   
JSS is manifest packaging tapp to C:\...\AppData\Local\Temp\tmp-52900G0A3kyGFGNy1\package\tempPackage.manifest.zip...
Adding sitecore-import.json
Wrote C:\...\AppData\Local\Temp\tmp-52900G0A3kyGFGNy1\package\tempPackage.manifest.zip\tapp.1612293689528.manifest.zip
Sending package C:\...\AppData\Local\Temp\tmp-52900G0A3kyGFGNy1\package\tempPackage.manifest.zip\tapp.1612293689528.manifest.zip to https://----.local/sitecore/api/jss/import...
Unexpected response from import service:
Error: unable to verify the first certificate

C:\...\node_modules\@sitecore-jss\sitecore-jss-cli\dist\cli-shared.js:11
    throw err;
    ^
undefined

When deploying my JSS app to sitecore, I had a similar certificate issue and had to use --acceptCertificate, but I understand that isn't accepted for deploy component.

This is a local instance of sitecore I'm using. Still kind of confused about whether I'm actually using connected or disconnected mode, since it's a local instance of Sitecore. Any help is appreciated. I haven't had a lot of luck searching for answers.

0

This issue occurs due to Node not trusting certificates added to Windows root Certificate Authority list. If you're using https with Sitecore locally, it's likely you'll need to whitelist that specific certificate to Node when running jss cli commands.

This is done (as you mentioned) using the --acceptCertificate flag. I believe this is supported by the deploy component command in all recent versions. To confirm, check the available parameters for this command in the CLI.

jss deploy component --help

Based on your example you would need to run something like:

jss deploy component Form --allowedPlaceholders jss-main --acceptCertificate yourCertThumbPrint

If you're not sure what the thumbprint should be, just run it as above (with a junk thumbprint) and the command will fail and print out the expected thumbprint. You can then replace it and run again. NB: Make sure your deployUrl in scjssconfig is set to the correct instance!

As for local vs disconnected, you may need to do some reading on the differences and architecture of each. However, note that if you are using forms with JSS, you should use connected mode. Disconnected is not currently supported. This is noted in the Limitations section of the JSS Forms documentation:

Forms cannot be defined or rendered in disconnected (connected, integrated, headless are supported)

https://jss.sitecore.com/docs/techniques/forms

1
  • Awesome! Thank you. I was wrong, you are right: --acceptCertificate is supported for deploy component. – T Lementz Feb 3 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.