2

I am trying to set up already existing TDS in my local Visual studio. Whenever I build the solution I am getting the below error repeatedly.

The package builder failed. Please set the build logging level to Normal or Detailed and see the build output log for more information on the failure this error is getting triggered at the HedgehogDevelopment.SitecoreProject.targets (Line 177,5)

For this issue, I have updated the options from minimal to Diagnostic in build & run. And then I tried again to find the root cause from build/team development for the Sitecore output window but there are no errors listed.

Can anyone help me with the above issue?

1
  • I am seeing the same error in TeamCity, whereas I can build using Visual Studio in my local successfully. Any suggestions?
    – MKZ
    Sep 12, 2022 at 5:59

1 Answer 1

2

Go to your TDS project properties and turn off generate package during build check box

enter image description here

also turn off Build web deployment project under Web Deployment Package

enter image description here

and build the project, this should fix the build issues. once the build is successful, turn on the Generate package during build or Build WebDeploy package or both based on which one you need for your project and rebuild the project.

If you still get the error, try reinstall the TDS for the version of Visual studio you are using and try the steps above.

4
  • Hi Mahesh, The above listed checkboxes are already in turned off state only. Also I have tried reinstalling & installing the TDS again but still same problem exists.
    – Harish
    Feb 3, 2021 at 11:09
  • Hi @Jay, do you have multiple TDS projects in your solution? Feb 3, 2021 at 11:28
  • Hi @Mahesh , Yes we have multiple projects , so I followed your steps & unchecked the boxes. Now build is successful. Thank you.
    – Harish
    Feb 8, 2021 at 7:56
  • Good to know it worked, mark my response as accepted answer, so it will be useful for others Feb 8, 2021 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.