1

Sitecore media field and icon is broken after unpublishing sitecore media item. How to handle this?

We are using Sitecore 9.3

Below is the stacktrace error.

[ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
Parameter name: delta]
   System.Web.HttpCachePolicy.SetMaxAge(TimeSpan delta) +193
   System.Web.HttpCachePolicyWrapper.SetMaxAge(TimeSpan delta) +15
   Sitecore.Resources.Media.MediaRequestHandler.SendMediaHeaders(Media media, HttpContextBase context) +467
   Sitecore.Resources.Media.MediaRequestHandler.DoProcessRequest(HttpContext context, MediaRequest request, Media media) +357
   Sitecore.Resources.Media.MediaRequestHandler.ProcessRequest(HttpContext context) +57
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +884
   System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) +232
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +100

enter image description here

4
  • What is the full exception stack trace? Can you check in logs? Feb 10, 2021 at 12:03
  • it is too long and not letting me add here. I am adding it in question
    – S. Ray
    Feb 10, 2021 at 12:06
  • I would check this field in sitecore database browser. We had once corrupted field and had to transfer item from web back to master to fix it. Check log in log.txt in your app_data folder or if no access to server then using desktop mode, reporting tools and log viewer. Also maybe try to reset field button too.
    – Kamil
    Feb 16, 2021 at 19:17
  • Any luck on solving this? i am facing the same issue.
    – alex
    Jan 12 at 15:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.