2

Currently Coveo is returning zero results. When I looked into Admin interface, I see all documents now say You do not have the permissions to view the document properties. Earlier this was not the case.

Only difference I see is, we now have workflow/security roles applied on items. Although site is still accessible to anonymous user, only content editing security rules applied. Coveo indexing still uses admin login to index item as per configuration settings.

How to troubleshoot this? Things I've tried so far: - Updated security cache - Deleted indexes and rebuild again from scratch

Using Coveo for Sitecore 3.0 and CES 7.0 8388 with Sitecore 8.1 update 3.

  • What user were you logged in as when you tried to view the document properties? If not admin, which roles/permissions did your user have? – Zachary Kniebel Nov 22 '16 at 18:10
  • I was logged in as myself (domain user). The issue I see is, the document should have at least read anonymous access, but it doesnt appear to have any. – xoail Nov 22 '16 at 18:40
  • I see you accepted my answer, what was the issue exactly? – Simon Langevin Nov 29 '16 at 15:50
  • 1
    @SLangevin It was due to the fact that coveo was unable to reach the sitecore instance. Your answer helped in troubleshooting steps. – xoail Nov 29 '16 at 17:00
2

I see two problems in your question. First of all, you do not have any results on your search. In order to tackle this, you will need to solve your second problem, which is being able to see the document's properties.

To see documents properties, you will need to give yourself "Index Browser - Full Access" Permissions. You can do this in the the Coveo Administration Tools (CES7) by default on [coveoserver]:8081. Simply navigate to Configuration >> Security >> Roles. Then select your user and give the Full Access permission.

For more information, please read: https://onlinehelp.coveo.com/en/ces/7.0/administrator/about_administration_roles.htm

Also, a quick search on search.coveo.com would have told you everything: https://search.coveo.com/#q=you%20do%20not%20have%20permission&sort=relevancy

Now that this is solved, you will be able to see the permissions tab in the detail section of your document in the Index Browser, with this, you will be able to know who has access to your document.

On the query side, use the CES Console to view the permissions on the user at query time, then compare with the information you have on the document in the index browser.

Now a common issue is when no permissions are applied on the documents, this is a normal behavior of Coveo when it encounters a failure while refreshing the securities. It will simply deny everyone to avoid a security leak. What kind of failure you will ask? Well a security cache refresh failure is a common one. The cache refreshes by default every day at midnight server time. You can manually refresh it to test : https://onlinehelp.coveo.com/en/ces/7.0/administrator/refreshing_security_caches.htm

Keep the good old CES Console open during the refresh an you will see the errors in bright red. From there you should be able to see the cause of your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.