5

I'm having an issue keeping my containers running consistently. After I run docker-compose up -d, some of them stop unexpectedly after only 10-15 minutes, sometimes less. When I run docker ps -a to see status, all the ones that stopped have the status Exited (4294967295) 2 minutes ago.

Has anyone encountered and solved this issue?

Setup

  • My topology is a mix between xc1-cxa and xc0 with an effort to combine SXA with the minimum number of containers
  • I'm using nested virtualization (VMware ESX host, Windows 10 Enterprise 20H2 as the Docker host)
  • I'm using hyperv isolation
  • I'm low on memory, but it's not running out completely when all the containers are up (22 GB used of 24 GB)

Here is an example docker ps -a after some containers stop: List of container statuses with some stopped Note: the containers that stop aren't always the same ones.

This is the data from docker inspect of one of the stopped containers, under the "State" property:

"ExitCode": 4294967295,

"Error": "failed to shutdown container: container 0d081f8951534817853cca3386c9256a72bd5ecb9a5ddf366394b9a1c0de1ee5 encountered an error during hcsshim::System::Shutdown: failure in a Windows system call: The remote procedure call failed and did not execute. (0x6bf): subsequent terminate failed container 0d081f8951534817853cca3386c9256a72bd5ecb9a5ddf366394b9a1c0de1ee5 encountered an error during hcsshim::System::Terminate: failure in a Windows system call: The remote procedure call failed and did not execute. (0x6bf)"

3

Depending on your version of VMware Tools in the Windows OS (mine was 11.0.5), you need to disable VMware's appinfo plugin.

On your Docker host, open an Admin PowerShell prompt and run the below command to fix it (you may need to reboot):

& 'C:\Program Files\VMware\VMware Tools\VMwareToolboxCmd.exe' config set appinfo disabled true

More info

This appears to be caused by the appinfo plugin polling for status of running processes and failing to get information back in time, which makes it shut them down. The resolution was found in this VMware support article.

More details on the plugin

The appinfo plugin collects the information about running applications inside the guest and publishes the information to a guest variable. For each application running inside the guest, the name and version information is captured and published by the plugin. This application information is collected by default.

More details on this specific issue

https://kb.vmware.com/s/article/78550

Symptoms

In 64-bit windows Guest VM, few 64-bit applications may crash (exit abruptly). The corresponding services for those executables may stop.

  • Few applications/services which are affected: Veritas NetBackup service / bpinetd.exe and Docker engine for Windows.

Cause

In VMware Tools 11.0.0, a new plugin called 'appInfo' was bundled. This new plugin runs every 30 minutes (can be configured by the guest administrator) to capture the information about running processes. For this, the plugin creates a remote thread in the target 64-bit process to capture the 'command line' of the target process. If the 64-bit application of the process is not built with '/LARGEADDRESSAWARE:YES, 'the remote thread' crashes the application.

Resolution

This issue is fixed in VMware Tools 11.0.6. For more information, see VMware Tools 11.0.6 Release Notes.

Workaround

To work around this issue, turn off the appinfo plugin inside the guest VM using vmwaretoolboxcmd.exe config set appinfo disabled true.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.