1

I am trying to install Sitecore 10.1 through SIF but I am getting the below exception..

Cannot retrieve the dynamic parameters for the cmdlet. Cannot validate argument on parameter 'Source'. The Test-Path $_ -Type Leaf validation script for the argument with value .\createcert.json did not return a result of True. Determine why the validation script failed, and then try the command again.

4 Answers 4

2

I was facing exactly the same issue and I did not have any previous Sitecore versions installed on my machine. So the above fix did not work for me:

So I found the root cause, I made a very silly mistake but added my answer so that others can refer and avoid doing the same mistake again.

When we download Sitecore installer(graphical UI), it is zipped, and I was trying to install Sitecore software without unzipping the .zip(Sitecore 10.2.0 rev. 006766 (Setup XP0 Developer Workstation rev. 1.4.0-r5).zip) folder.

I thought, it might work without unzipping and going ahead, but it failed, after that I unzipped it and it worked fine eventually.

2
  • I am also facing same issue even after unzipping and also i do not have any existing certificates. Apr 29, 2022 at 10:21
  • were you trying to install it from zipped folder earlier, if so then delete all the newly created files and try to re-install it. May 4, 2022 at 9:20
1

I was able to resolve this issue by removing all Sitecore 10.1 related certificates from mmc and start the setup again.

Steps

  1. From Run window type mmc and hit ok
  2. From file menu, click on "Add or Remove Snap-Ins"
  3. Select Certificates and click "Add" and then "Ok"
  4. Expand "Personal" folder and click on "Certificates"
  5. Search for any existing certificates that are related to Sitecore 10.1
  6. Delete those certificates.

enter image description here

1
  • I am facing exactly same issue and I do not have previous sitecore versions installed in my machine. So the above fix will not work for me. Mar 23, 2022 at 17:49
1

This error can sometimes occur if the file path in the source parameter is not properly escaped.

Please check XP0-SingleDeveloper.json (or whatever the relevant file is for your topology) and ensure that any place you are passing createcert.json in to the Source parameter there is a double slash.

"Source": ".\\createcert.json"
0

Error can occurs when you have different installation path than the file where createcert.json is located.

Solution -> copy createcert.json file to installation folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.