1

I am using sitecore 10 with JSS, and I deployed the app to sitecore but when I am trying to open the site it gives me errorenter image description here

Also i checked this link Node render engine project directory path '{website-path}\app' does not exist and the App name and site name in te config file and they are the same. enter image description here

the site is deployed in sitecore tree correctly as below enter image description here

but the jss site not added here C:\inetpub\wwwroot{{Sitecore Instance name}}\dist is there any reason for this error??

6
  • Do you finally have C:\inetpub\wwwroot\sc10.dev.localsc.dev.local\dist\atlp-informational-web folder exists with the built jss app? – Artem Prashkovich Mar 1 at 14:23
  • no it is not there, I found that i have "borwser, server folders and server.bundle.js file" added to the root of my sitecore instance however it should added to "dist" folder – shimaa elsayed Mar 2 at 12:17
  • Could navigate to the root of your JSS app and run the jss deploy files command. But previously make sure that you have scjssconfig.json with instancePath configured which should pint your website root. – Artem Prashkovich Mar 2 at 12:24
  • still the same the folders added to the root directly, even the instance path configured correctly in scjssconfig.json i tried to create new folder with the app name in the dist and move the "borwser, server folders and server.bundle.js file" to it, but i got this error Error Rendering Sitecore.JavaScriptServices.ViewEngine.Presentation.JsLayoutRenderer: document is not defined ReferenceError: document is not defined at AppComponent.setAttributesLangDir (C:\inetpub\wwwroot\sc10.dev.localsc.dev.local\dist\atlp-informational-web\server.bundle.js:48147:1398297) – shimaa elsayed Mar 2 at 12:51
  • Try to copy that to the dist folder manually – Artem Prashkovich Mar 2 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.