1

Getting issue in the order to publish sites, all conflicts have to be resolved but the arrows are not working in SXA Site Manager. I select site and click move up or down and it appears to process but it does not reflect change on page.

Using Sitecore 9.2, Sitecore Experience Accelerator 1.9.0, Chrome browser. I do not get an error, it seems to process but the screen does not change.

enter image description here

Here is the SPE log info

19276 10:26:11 INFO Executing PsSitecoreItemProvider5.Start(providerInfo='Sitecore')
6864 10:26:11 INFO Script item set to master:\system\Modules\PowerShell\Script Library\SXA\SXA - Site Manager\Internal\List View\Ribbon\SiteDefinitionModel\Move Up in ScriptSession $scriptSession$|v2xkv4zd0nonxnotqi4widwt|0f4d4b60-a227-4890-9c50-9f78e8db7686.
ManagedPoolThread #7 10:26:11 INFO Executing a script in ScriptSession '$scriptSession$|v2xkv4zd0nonxnotqi4widwt|0f4d4b60-a227-4890-9c50-9f78e8db7686'.
ManagedPoolThread #7 10:26:12 INFO The script execution in ScriptSession '$scriptSession$|v2xkv4zd0nonxnotqi4widwt|0f4d4b60-a227-4890-9c50-9f78e8db7686' completed in 850 ms.
2
  • Welcome to sitecore stack exchange. Could you please add more details regarding the error you are getting, for example some print screens, sxa version or if you are seeing any errors in the browser console? – Cristi Vulturar Mar 3 at 21:18
  • Question updated – GMarville Mar 4 at 15:57
0

If I recall correctly, you can only move SXA sites between other SXA sites.

The 'website' and 'exm' sites are defined in configs and intended to be resolved after SXA sites (see Sitecore.XA.SitesToResolveAfterSxa.config).

If you move 'website' above the new site, the conflict won't be resolved ('website' will hide the new site instead). You can try adding a hostname to the new site so that it doesn't hide 'website'.

The 'exm' is intended to be last in the site order. It will be always in conflict state with 'website'.

Anyway I believe you should look into the initial error when trying to publish sites - you sure it is the site order conflict that causes it?

3
  • Thank You for your response Andrey....... I added a host name and it removed the conflict from "website" Based on your statement above...."The 'exm' is intended to be last in the site order. It will be always in conflict state with 'website'." Does this mean I will never be able to remove the conflict from exm but site will publish? – GMarville Mar 5 at 20:40
  • Yes, I would expect publishing to work regardless of SXA site conflicts. Anyway the 'exm' site is not an SXA site and it doesn't have any content to be published. What is the error that prevents publishing? – Andrey Krupskiy Mar 8 at 12:09
  • That you Andrey. No errors. The site published. I just to wanted I understood what your statement meant. Thank you for all your help. – GMarville Mar 9 at 14:59
1

As a workaround you could try to manually change the sort order in content editor. You can find the main Site Manager item by going to /sitecore/system/Settings/Foundation/Experience Accelerator/Multisite/Management/Sites

enter image description here

Regarding the error in site manager, are you getting any script errors in the browser develop tools console?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.