0

I have added Bengali & Tamil in Sitecore 9.2. In publishing the data I am not getting any issue. But while running the indexing, getting the below error for the fields of the item.

copyField dest :'description_t_ta_str' is not an explicit field and doesn't match a dynamicField.
copyField dest :'description_t_bn_str' is not an explicit field and doesn't match a dynamicField.

In the Managed Schema file in SOLR for both the indexes (web & master) added the below lines based on the solution provided here Rebuilding Indexes with SOLR throws Exceptions.

<dynamicField name="*_t_ta" type="text_general" indexed="true" stored="true"/>
<dynamicField name="*_t_bn" type="text_general" indexed="true" stored="true"/>

But the result is the same. Kindly need your expertise for the same.

6
  • Have you also tried the solution described here vinayakchauhandotcom.wordpress.com/2019/06/27/…? Mar 6, 2021 at 16:22
  • It is already in place. <uniqueKey>_uniqueid</uniqueKey>
    – Arkadeep
    Mar 6, 2021 at 16:33
  • And also after restarting the CM server, the file is got overwritten
    – Arkadeep
    Mar 6, 2021 at 16:34
  • you've added *_t_ta to the schema, but your field has *_t_ta_str postfix - with _str, not sure why your sitecore adds it. Please check <fieldMap> config section for such postfix. It contains rules for generating field names, like {0}_s for strings and {0}_t for indexed text.
    – Daniil
    Mar 7, 2021 at 12:23
  • 1
    and I would recommend you to extend <contentSearch.PopulateSolrSchema> pipeline instead of editing solr schema files.
    – Daniil
    Mar 7, 2021 at 12:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.