1

On JSS deploy getting error:TypeError: Cannot read property 'forEach' of undefined In the Sitecore log, the error mentioned is: "Import requested wipe import on 'jsssitename' but wipe imports are disabled on the SXA JSS sites".

Environment: Sitecore 9.3 and JSS (Sitecore JavaScript Services Server for Sitecore 9.3 XP 13.0.0 rev. 190924.zip).

I have created a new JSS react app and trying to deploy it in the SXA site under the JSS tenant, layout service is working fine and returning valid JSON. The sitecore site and JSS site are on HTTPS and have assigned proper SSL cert. In Sitecore, JSSImport user has given rights to jss site:

enter image description here

To deploy app to sitecore, giving command : jss deploy app -c -d --acceptCertificate It gives below error:

enter image description here

In the Sitecore log file, it entered below details:

enter image description here

Please let me know what:

  1. am I missing something and do share if have any doc which has step-by-step details to configure and deploy SXA/JSS site.

  2. For sxa site in .config, should we change rootPath="/sitecore/content/" to rootPath="/sitecore/content//" or is it not needed?

3
  • Welcome to sitecore stack exchange. Have you tried changing the SitecoreJSS.WipeAllowed setting to false to see if the wipe import error is still happening? Mar 7 at 18:39
  • Thanks @CristiVulturar for reply, tried with false as well but no luck... :( , one more thing in log it also says "/sitecore/content/JSS Workshop Tenant/jssworkshop/home has ID {260B6370-2D73-4DDA-BAC0-3C767B7F7377}, which does not match the expected consistent ID {F008E7F4-293C-5D92-8BE4-72CE6448C6D2}", but i have search "{F008E7F4-293C-5D92-8BE4-72CE6448C6D2}", it didn't exist in my sitecore instance so from where it picking this ref, but have other id mentioned against home-item(/sitecore/content/JSS Workshop Tenant/jssworkshop/home)
    – Rinku Jain
    Mar 8 at 6:06
  • Got the solution, it was due to incompatible version of JSS app with sitecore version. So need to create jss app with 13th branch will resolve this issue... :) syntax: jss create appname react -b release/13.0.0
    – Rinku Jain
    Mar 10 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.