2

I was trying to implement search functionality with Solr on Sitecore 10.1 instance. But I am not able to find the following default indexes:

  • sitecore_web_index
  • sitecore_master_index
  • sitecore_web_core

enter image description here

Some notes: i. Solr is up and running smoothly ii. All Solr config files inside app_config are enabled, (Examples folder, ContentSearch folder)

A snapshot of Solr cores: enter image description here

Are there any settings I'm missing? Any help would be highly appreciated. Thanks community for your immense help, I'm looking forward to a solution.

Update:
The above issue was caused by adding all the Solr config files which were present inside <instance>\App_Config\Include\Examples folder, which had these files:

  • Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild.config
  • Sitecore.ContentSearch.Solr.SwitchOnRebuild.config

The above files overrode Solr default config files and switched to Solr cloud.
Thanks to @Cristy for his help. Disabling the Solr cloud configs fixed the issue.

Hope this helps anyone who is facing this issue.

6
  • Thanks Cristi for your help again, yes I have that file inside ContentSearch folder, which also includes Sitecore.ContentSearch.Solr.Index.Core.config, Sitecore.ContentSearch.Solr.Index.Master.config, Sitecore.ContentSearch.Solr.Index.Web.config
    – Suman Baul
    Mar 9, 2021 at 7:55
  • Can you verify in /sitecore/admin/Showconfig.aspx what configration you have for sitecore_master_index? And if you deployed all schemas to solr, I can see from printscreen that you have lindesc_? Mar 9, 2021 at 8:02
  • Try repopulating indexes and then restart solr Mar 9, 2021 at 8:03
  • @CristiVulturar While inspecting Showconfig.aspx, Im able to find sitecore_master_index inside patch:source="Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild.config".
    – Suman Baul
    Mar 9, 2021 at 8:13
  • @Mahesh Just did, didnt change anything!
    – Suman Baul
    Mar 9, 2021 at 8:15

2 Answers 2

2

I assume that the file Sitecore.ContentSearch.Solr.Index.Master.config is present in the \App_Config\Sitecore\ContentSearch\ folder. When verifying with /sitecore/admin/ShowConfig.aspx page you should be seeing the definition of <index id="sitecore_master_index" in the configuration.

If you take a look at the definition of the indexes they all have <sitecore role:require="Standalone or ContentManagement" search:require="solr">, could you verify in web.config if you have <add key="search:define" value="Solr"/> set and <add key="role:define" value="Standalone"/>?

I am not sure why you have Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild.config enabled, by default this file is disabled. If you take a look in it there are some <patch:delete /> for the sitecore_master index. If you don't have solrcloud you should comment out this file or try to use Sitecore.ContentSearch.Solr.SwitchOnRebuild.config instead.

3
  • Thanks Cristi, I have checked, <add key="role:define" value="Standalone"/> and <add key="search:define" value="Solr"/> are present in the web.config file
    – Suman Baul
    Mar 9, 2021 at 10:32
  • I updated the answer, please take a look at why you have Sitecore.ContentSearch.SolrCloud config enabled. Mar 9, 2021 at 11:03
  • Ah Thanks a lot @Cristi. You are like god of Sitecore to me ^_^ It worked, I just disabled the Sitecore.ContentSearch.SolrCloud.SwitchOnRebuild.config file, which I accidentally enabled following a Sitecore blog on the net. Thanks a lot for the help! Kudos!!
    – Suman Baul
    Mar 9, 2021 at 11:28
0

I had the same problem as you, but my solution was a little different so adding it here for future reference.

It turned out that these 3 files:

Sitecore.ContentSearch.Solr.Index.Core.config
Sitecore.ContentSearch.Solr.Index.Master.config
Sitecore.ContentSearch.Solr.Index.Web.config

Found under "~\App_Config\Sitecore\ContentSearch" were getting overwritten by the custom solution ones of my project, and the <param desc="core">INSERTCOREINDEXNAME</param> field inside them looked like <param desc="core">{id}</param> rather than have the correct core name inside it

Once I fixed the 3 params to include the correct core names they showed up in my instance's index manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.