2

I have Windows Authentication on the IIS of sitecore site (for limited external access). Coveo is running remotely on another server. When trying to run Coveo diagnostic tool, I see the 401 error in Coveo Security Service.

System.Net.WebException: The remote server returned an error: (401) Unauthorized.
   at System.Net.HttpWebRequest.GetResponse()
   at Coveo.SearchProvider.Applications.StateVerifier.<>c__DisplayClass16.<GetWebServiceState>b__15()
   at Coveo.SearchProvider.Applications.BaseVerifier.VerifyComponent(Func`1 p_VerifyMethod, String p_ComponentName)

I've tried to follow this other post on how to configure this but I am running into same issue. The CES service is running on an AD account (domain/username) that has access to sitecore site's IIS. I am able to login using the same AD account.

Any ideas what else I should be configuring to make this work?

2

You can follow the steps on this link. But basically this is what you need to do:

Navigate to IIS, and open the Sitecore site. Browse the folders and select Coveo’s main folder. With the Coveo folder selected, click Authentication on the right side. Choose Windows Authentication and select disable, then choose Anonymous and select enable.

Go back to the left panel, navigate to modules > Web > Coveo folder And do the same thing.

This should take care of your issue

| improve this answer | |
  • This works great in resolving the Security Service issue. Although now I am stuck with p_Args.CoveoItem.BinaryData throwing 401 errors in the log while indexing. Basically we have a custom processor to get html contents of the page before indexing. I've update question to add the error. – xoail Nov 23 '16 at 17:49
  • Please create a new question as this doesn't have to do with the original question which has been answered. This helps organize the forum – Diego Nov 23 '16 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.