0

I'm using Sitecore 10.

I want to create a custom condition and have it show when creating a new marketing automation campaign as an option when creating a "rule" for starting the campaign. I need the condition to appear in the section shown in this image

enter image description here

I followed the steps found in this article Here, and added the required sitecore items, and added my new custom condition tag to "/sitecore/system/Settings/Rules/Conditional Renderings/Tags/Default"

However, it does not appear in my required marketing automation rule panel, it only appears when trying to personalize items within the content node of my site (which is expected)

My question is where do I need to add my tag so that my conditions would appear in marketing automation? I have tried to search online and didn't find an answer, and tried some of the other nodes below "/sitecore/system/Settings/Rules", like "/sitecore/system/Settings/Rules/Marketing Workflows/Tags/Default" and "/sitecore/system/Settings/Rules/Rule Elements Visibility/Tags/Default" but none of them reflect in marketing automation as well.

Is there a step I am missing? what can I do to add a custom condition to the marketing automation rule creation window?

1

You can create a new rule set under the item /sitecore/system/Settings/Rules/Definitions/Elements, each element having a Group field where you can set where you would like it to appear in the view window. Under each defined item element you have the ability to create your custom rules.

If I duplicated the XConnect - Campaign item for example and changed its name I was able to see it in the rule list window in marketing automation.

enter image description here

enter image description here

2
  • Thank you, your answer helped, I had already created my own rule set under "Elements", and compared my new set to the one you mentioned in the answer, and found the "group" field empty in mine, once i assigned a "group" to my rule set it appeared, but for it to appear as a separate section I actually had to add "XConnect - Condition" and "XConnect - Search Query" to my new rule set's Default Tag. Mar 9 at 17:01
  • Great to see that it worked, it would help marking my answer as helpful :) Mar 9 at 17:38
1

I found out how to do it:

  1. if you want to add your new rule set to an existing group (like Contact, Campaign, Channel, etc.) Then just assign a group to your new rule set from here

enter image description here

  1. if you want your rule set to appear as a separate section, then you need to add "XConnect - Condition" and "XConnect - Search Query" to your new rule set's Default Tag, and it should appear in the conditions list afterwards for marketing automation campaigns.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.