0

When I try to relink an Item on archive to another item I get the following error

Job started: Relink|System.ArgumentNullException: Value cannot be null.
Parameter name: path
   at Sitecore.Diagnostics.Assert.ArgumentNotNull(Object argument, String argumentName)
   at Sitecore.Data.DefaultDatabase.GetItem(String path)
   at Sitecore.Data.Fields.LayoutField.Relink(ItemLink itemLink, Item newLink)
   at Sitecore.Shell.Applications.Dialogs.BreakingLinks.BreakingLinksForm.Relink.RelinkLink(Item sourceItem, ItemLink itemLink)
   at Sitecore.Shell.Applications.Dialogs.BreakingLinks.BreakingLinksForm.Relink.RelinkItemLinks(LinkDatabase linkDatabase, Item targetItem, Boolean relinkCloneLinks)
   at Sitecore.Shell.Applications.Dialogs.BreakingLinks.BreakingLinksForm.Relink.RelinkItemLinks(LinkDatabase linkDatabase, Item targetItem, Boolean relinkCloneLinks)
   at Sitecore.Shell.Applications.Dialogs.BreakingLinks.BreakingLinksForm.Relink.RelinkItemLinks(LinkDatabase linkDatabase, Item targetItem, Boolean relinkCloneLinks)
   at Sitecore.Shell.Applications.Dialogs.BreakingLinks.BreakingLinksForm.Relink.RelinkItems()|Job ended: Relink (units processed: 1)

Anyone had this issue and know how to resolve this? We are using Sitecore 9.3

Tried rebuilding link databases with no luck.

5
  • can you add your code which is doing relink ? Mar 10, 2021 at 6:34
  • Have you tried rebuilding link database from Control Panel first?
    – Marek Musielak
    Mar 10, 2021 at 6:36
  • is not custom code, its builtin function Mar 10, 2021 at 6:41
  • yes, I did do rebuild link database Mar 10, 2021 at 6:42
  • Most likely the xml in the rendering field of the layout section of the itemlink is corrupted. Mar 14, 2023 at 23:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.