0

I am using Sitecore PowerShell extensions 5.0 and I have a script written to pull some data from the Sitecore tree. The Script run without any issues until it produces the report. Once the report is populated. I can download the reports for first serval attempts and then it fails with a 500 error. No regular pattern observed it is just happen randomly and very frequent during the server busy times(app service). This is a particular issue only happens in the production site hosted in azure app service. My local environment works fine. I try to replicate it but I couldn't. The only instance I saw this error was during the recycling of the app pool.

I am attaching error below. I suspect this has something to do with sessions but not sure, it's a wild guess

Please let me know your thoughts on this

    System.Web.HttpUnhandledException:
   at System.Web.UI.Page.HandleError (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.UI.Page.ProcessRequestMain (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.UI.Page.ProcessRequest (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.UI.Page.ProcessRequest (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.UI.Page.ProcessRequest (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.HttpApplication+<>c__DisplayClass285_0.<ExecuteStepImpl>b__0 (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.HttpApplication.ExecuteStepImpl (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.HttpApplication.ExecuteStep (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
Inner exception System.NullReferenceException handled at System.Web.UI.Page.HandleError:
   at Cognifide.PowerShell.Client.Controls.PowerShellListView.get_FilteredItems (Cognifide.PowerShell, Version=5.0.0.42513, Culture=neutral, PublicKeyToken=null)
   at Cognifide.PowerShell.Client.Applications.PowerShellResultViewerList.SetVariables (Cognifide.PowerShell, Version=5.0.0.42513, Culture=neutral, PublicKeyToken=null)
   at Cognifide.PowerShell.Client.Applications.PowerShellResultViewerList.ExecuteScriptJob (Cognifide.PowerShell, Version=5.0.0.42513, Culture=neutral, PublicKeyToken=null)
   at Cognifide.PowerShell.Client.Applications.PowerShellResultViewerList.ExportResults (Cognifide.PowerShell, Version=5.0.0.42513, Culture=neutral, PublicKeyToken=null)
   at Cognifide.PowerShell.Client.Applications.PowerShellResultViewerList.HandleMessage (Cognifide.PowerShell, Version=5.0.0.42513, Culture=neutral, PublicKeyToken=null)
   at Sitecore.Shell.Framework.Commands.MessageCommand.Execute (Sitecore.Kernel, Version=11.1.0.0, Culture=neutral, PublicKeyToken=null)
   at Sitecore.Web.UI.Sheer.ClientPage.Dispatch (Sitecore.Kernel, Version=11.1.0.0, Culture=neutral, PublicKeyToken=null)
   at Sitecore.Web.UI.Sheer.ClientPage.RaiseEvent (Sitecore.Kernel, Version=11.1.0.0, Culture=neutral, PublicKeyToken=null)
   at Sitecore.Web.UI.Sheer.ClientPage.OnPreRender (Sitecore.Kernel, Version=11.1.0.0, Culture=neutral, PublicKeyToken=null)
   at System.Web.UI.Control.PreRenderRecursiveInternal (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
   at System.Web.UI.Page.ProcessRequestMain (System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)

Thank you

1
  • Is it possible that the HTTP cache has expired? Perhaps the data is lost? Mar 10 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.