I have Sitecore 9.3 version and followed the steps described here https://jss.sitecore.com/docs/getting-started/jss-server-install to setup JSS server. I am not able to deploy the app while running deploy command, I am receiving the error

Unexpected error processing reply from import status service:
TypeError: Cannot read property 'forEach' of undefined
at C:\jss\jss-app\node_modules\@sitecore-jss\sitecore-jss-dev-tools\dist\package-deploy.js:238:42 at processTicksAndRejections (internal/process/task_queues.js:93:5)

Anyone know how to solve this issue. Thanks in advance.


4 Answers 4


This issue can happen due to incompatible version of JSS app with sitecore version. Can you verify what version you have used when creating your jss app?

For sitecore 9.3 you need to create jss app using release/13.0.0 by this syntax: jss create appname react -b release/13.0.0. You can verify the JSS module compatibility with the sitecore version on the page https://kb.sitecore.net/articles/541788

  • 1
    Thanks @Cristi Vulturar, only your comment has help me. Commented Apr 16, 2021 at 6:42
  • 1
    Indeed this is the fix. I am running sitecore version 10 and the JSS app version was 16.0. i too got the same issue and created a new app with jss create appname angular -b release/15.0.0 fixed the issue. i.e compatible JSS version
    – JTC
    Commented Apr 29, 2021 at 12:23
  • So @Kanniyappan Krishnan, can we mark this as the right answer? Have you tested? Commented Feb 23, 2023 at 17:55

I have got the same error for Sitecore 10.x version. I have followed the below steps to resolve the error:

  1. Uninstall npm Sitecore JSS in the global and local path(where your code placed)
   npm uninstall -g @sitecore-jss/sitecore-jss-cli
   npm uninstall -i @sitecore-jss/sitecore-jss-cli
  1. Again install the Sitecore JSS package.
   npm install -g @sitecore-jss/[email protected]
   npm install -i @sitecore-jss/[email protected]

The version mentioned should match with the installed packages Sitecore Headless Services Server for Sitecore 10.1.0 XM 16.0.0 rev. 210223.zip.


I faced many issues and struggled about 3-4 days, now I just realised. To avoid Jss app deployment issues, make sure jss-sitecore-cli and jss server module have the same version.

For this purpose execute below command with specific version. e.g. you have installed "Sitecore JavaScript Services Server for Sitecore 10.0.0 XP 15.0.1 rev. 201112.zip" package for Sitecore 10.0.1.

npm install -g @sitecore-jss/[email protected]

Hope it will be helpful.

Thanks, Akif


Also make sure both your global jss cli version and the jss cli version in your project's package.json match!

I had this same error: Error running `jss deploy app`: TypeError: logReplies.forEach is not a function

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.