1

I am using Sitecore 9.0.1 with SXA 1.7. By default the SXA Image component comes with a field editor button to add link to an image. Can anyone please explain how this can be achieved.

enter image description here

The default Promo component image field doesn't have that button to add the link.

enter image description here

Created a new Custom button in Custom Experience button under core db after that added this new button to my sxa component.Button is appearing but when clicked it is showing empty fields.

enter image description here

enter image description here

enter image description here

1

The image component has an Experience Editor Button. If you check the item /sitecore/layout/Renderings/Feature/Experience Accelerator/Media/Image you will see that the field "Experience Editor Buttons" there has a selection "Edit Image". This is the button that is added in the XP editor.

You can achieve similar functionality with Edit Frames (edit frames can be added through the variants).

More information on both options can be found in this blog: https://himynameistim.com/blog/custom-experience-buttons-vs-edit-frames-in-sitecore

From that blog:

To set up a custom experience button:

  • In the core database navigate to /sitecore/content/Applications/WebEdit/Custom Experience Buttons and create a new item based on Field Editor Button.
  • On your button item make sure you set an icon and the list of fields the button should allow the content editor to edit. These should be pipe separated.
  • Switch to the master DB and navigate to the rendering item for your component
  • In the field for Experience Editor Buttons select the new button

Update

In the Fields section of the button you have to add the exact names of the fields you want to add. As far I can see in the screenshot, you didn't use the names of the fields of a Promo template so that is the reason the editor is blank (the fields you added do not exist in that context)

2
  • Followed your steps but not able to see the fields which i have added in the field editor button it is showing blank. Added the scrnshots in the question @Gatogordo
    – Vinaya
    Mar 24 at 7:54
  • Added to the answer..
    – Gatogordo
    Mar 24 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.