1

I am using Sitecore 9.0.1 with SXA 1.7. I have created a Chinese language and a version for the language. I have added Chinese content for a page and in the site grouping of site specified the language as CN. But when I browse the page I am not able to see Chinese content. If I specify the language in the query string I am able to see the Chinese content.

In the preview mode of the page I am able to see CN content.

enter image description here

Is it possible to browse the CN content without specifying the language in the query string?If yes please explain how can i achieve that.

enter image description here

Update

Created a Patch File under Appconfig/Include named as sitedefinition.config and added the language and other paths as shown in the below screenshot but still I'm getting a blank page as above screenshot.

enter image description here

0

Peter got you on the right path by defining a default language for the site, but as you are using SXA you shouldn't (or can't) do that with a config patch. (you can remove that again)

To set a default language in SXA you just need to set it in the site definition fields for that site: https://doc.sitecore.com/developers/sxa/18/sitecore-experience-accelerator/en/the-sxa-site-definition-fields.html

You can change the site definition fields in /sitecore/content/<tenant>/<site>/Settings/Site Grouping/<site>. You can also access these fields from the SXA Site Manager. The SXA site definition items are equivalent to Sitecore nodes that you define within your config file if you build the site without SXA.

Set the field Language to the desired default language (and publish).

Of course, if you have multiple languages you should use a language switch...

Also:

  • make sure everything is published (including the language setting item and all paths from the root to your item. Might be best to do a full site publish)
  • if everything still fails: I noticed that you are testing a page on a first sublevel underneath your home. Does that home item also has a Chinese version? If not, create that as well.. (to make sure there is a Chinese path al the way to your page)
6
  • I am testing this under master DB and i have changed the language in sitegrouping also @Gatogordo – Vinaya Mar 25 at 8:20
  • And do you parent items have a Chinese version? – Gatogordo Mar 25 at 8:21
  • Yes parent item has chinese versions @Gatogordo – Vinaya Mar 25 at 8:22
  • Does it work on the homepage? Do you have a language cookie set? (try clearing you cookies if needed and maybe an other/incognito browser so you don't share a browser with your editing environment) – Gatogordo Mar 25 at 8:48
  • No it is not working on the Home Page too and cleared the cookies also maintaing different browsers @Gatogordo – Vinaya Mar 25 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.