2

Currently I have Sitecore 8.0 Update-1 and I want it to upgrade to 8.2. So as per the 8.2 upgrade guide, prerequisites for running this update is Sitecore 8.1 rev. 151003 (Initial Release) or later.

So I first decide to upgrade my current Sitecore 8.0 to 8.1.

As per the 8.1 upgrade guide, I have started to install the Sitecore Update Installation Wizard 1.0.0 rev.150930 but this update installation wizard never ends. I have tried 3 times. One wizard took more than 24 hrs but it never ends.

I am following the upgrade guide (Sitecore 8.1) step by step but still facing this issue.

Please help me on this.

  • 3
    Did you check the upgradehistory logs? Website\temp\__UpgradeHistory should have the log information. Do you see any issues there? – phani Nov 24 '16 at 6:53
  • In Website\temp, there is file or folder with the name of __upgradehistory. – user2753438 Nov 24 '16 at 7:17
  • @JaideepCharan you should see inside Website\temp__UpgradeHistory mentioned by phani a file named InstallationLog.txt. Can you check and update the question? – Vinicius Deschamps Nov 24 '16 at 8:54
  • Do you have MongoDB installed/configured? Or have disabled analytics? – jammykam Dec 2 '16 at 8:35
3

As Hdvti mentioned I've seen this when you have xDB enabled. As a workaround disable it in short term using the following patch file and then re-move the patch file after you have installed any modules:

<?xml version="1.0" encoding="utf-8"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
        <settings>
            <setting name="Xdb.Enabled">
                <patch:attribute name="value" value="false" />
            </setting>
            <setting name="Xdb.Tracking.Enabled">
                <patch:attribute name="value" value="false" />
            </setting>
        </settings>
    </sitecore>
</configuration>
2

Do you have xDB enabled? If yes, make sure Mongo Daemon Service is running. And check in the Sitecore data/logs for any MongoDB exceptions. I have run into this issue in past and turned out that Mongo Daemon wasnt running and that was causing interruptions in installing Sitecore updates/packages.

1

I faced a similar issue in my previous 7.2 to 8.2 upgrade.

In my case while executing the Upgrade Wizard (X version to Y), it goes fine till all steps and stuck on the last step, where basically it tries to delete temp files and copy new files. The wizard stucks here for hours until we close the browser.

Troubleshooting and call with Sitecore support helped me came up with various possible reasons blogged here. Please have a look and try the options:

https://sitecorecompetencies.com/2017/02/08/first-blog-post/

0

I have seen this issue too. When I installed it, it would not stop spinning but the logs showed that the installation was complete. In my case I just refreshed the page and confirmed that the installation succeeded which was the case

0

I faced similar issue before.

In my case giving application pool user permissions to Data folder fixed it.

In my case its trying to create packages folder in data folder and failing.

0

If you do not find an error in the Website \ temp \ __ UpgradeHistory, try first upgrade to a higher version of 8.0.x and after then try an upgrade to version 8.1.x.

I have solved the same problem in one of our customers, where we have upgraded to version 8.0-update5 and after then we upgraded to version 8.1.x.

I'm not quite sure, but maybe it will help you too.

Best regards, Jiri Semrad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.