I have created a command template and I want to create an item using that command template under the home item. I have assigned that command template on the insert options of the home item's template but when I right-click on the home item then in the insert options the command template is not visible.

If I create an item under the home with the same template (used for the home item) and then try to create an item under that by right click then I can see the command template available in the insert options.

Do you have any idea why on the home item the command template is not available even I have selected that template in the insert options of the standard values of the home item's template?

For example, my home item is created with the "Sample Item" template and I have assigned the command template on the insert options of this template.

If I do right click then I am not able to see the command template in the insert options (screenshot below): enter image description here

When I created an item with the same template (used for the home item) and then tried insert options then it was available (screenshot below). enter image description here

I am using Sitecore 9.3 and the same behaviour I noticed in Sitecore 9.0 as well.

  • You'll need to modify the "Insert Options" on the "Standard Values" of each template you want that option to appear. Mar 26, 2021 at 18:42
  • Your home item and Sample item icons look different, make sure both the items are using the same template, the template of which standard value you've configured the insert option. Refresh the content tree. Also, make sure you don't have any insert rule here /Sitecore/system/Settings/Rules/Insert Options/Rules which is contradicting your insert option. Mar 27, 2021 at 10:16
  • @MichaelWest I tried on standard values but still no luck. Mar 28, 2021 at 14:54
  • @RamanGupta Both are the same template, I tried this in the vanilla instance as well so this problem is there in the vanilla instance also. Mar 28, 2021 at 14:55

2 Answers 2


It's a common mistake - you need to assign the Insert Options on the Standard Values for the desired template; never on the template itself.

edit: I would reset the Insert Options field on the Home item. Select the item. select the versions ribbon, click Reset. Select the Insert Options field.

When you do that, you will undo any custom changes made to the home item and it will pull the insert options from the standard values.

  • I tried this as per your suggestion but it is not working in this case as well. Mar 28, 2021 at 14:53

Please reset the insert options on Sample Item Template Standard Values, Home Item and the Sample Item created under the Home Item and Save the template and items.

After that assign your Command Template to the Insert options of Sample Item Template Standard Values and Save the template. Doing this will also update the insert options on Home Item and the Sample Item created under the Home Item.

This should probably fix it and then please check the Insert options on both the items.

  • No @Dhananjay Kurekar, even this did not work I suspect that on the home item insert options are coming somewhere from the Sitecore's code logic because even after resetting I do not see any change. Apr 4, 2021 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.