1

I have installed Sitecore 10.1 & Sitecore Commerce 10.1 in my local machine and trying to run the example Customer.Sample.Solution.

The solution builds without any errors.

The following changes are made in Global.json.

type - Sitecore.Commerce.Plugin.SQL.EntityStoreSqlPolicy, Sitecore.Commerce.Plugin.SQL

Changed the username, password and server.

The following changes are made in Plugin.SQL.PolicySet-1.0.0.json.

type - Sitecore.Commerce.Plugin.SQL.EntityStoreSqlPolicy, Sitecore.Commerce.Plugin.SQL

Changed the username, password and server.

I selected the debugging profile as Engine in VS. The startup project is Sitecore.Commerce.Engine.

When I run the project after these changes, the error is:

Failed to bind to address http://localhost:5000

enter image description here

3
  • Did you try to rebuild the index manually by Sitecore control panel? Mar 30 at 6:26
  • Also check PlugIn.Content.PolicySet-1.0.0.json as well, does it have correct credentials. Mar 30 at 6:55
  • This issue was resolved by stopping the CommerceAuthoring website in IIS and then running the sample project.
    – Qwerty
    Mar 30 at 7:18
0

Yes, before start running the debugging in VS, you have to make sure that you have stopped your Website and related AppPool in IIS.

Another option for debugging is "Attach to process". In case of CE, the difference is that you have to attach to the executable Sitecore.Commerce.Engine.exe process and not to the regular w3wp process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.