1

When running:

jss deploy app --includeContent --includeDictionary --acceptCertificate XX:XX:XX:XX:XX:XX...

I get the error:

Sitecore has accepted import task JSSImport-myapp-2:59:34 PM
Unexpected error processing reply from import status service: TypeError: logReplies.forEach is not a function

I have verified:

  • Local Sitecore 10.1 instance is working correctly
  • JSS (16.0.0) packages installed to Sitecore instance (Also using SXA)
  • Using JSS CLI 16.0.0
  • Correctly and successfully ran jss setup and jss deploy config
  • Restarted machine

Existing JSS repo in React that works on over devs local environments.

But:

Looking in the log files everything looks good and the deploy worked! (Even though the shell errors out)

5
  • Hi Liam and welcome to Sitecore Community. This error you have received is coming from freshly created new JSS project or on existing code base? Which UI framework you have used? React/Vue/Angular? Mar 30 at 13:22
  • Using React. This is an existing code base that is working on other dev's local environments.
    – Liam
    Mar 30 at 13:39
  • Try to search in code base for "logReplies.forEach". Can you paste the code around? Mar 30 at 13:45
  • I think Unexpected error processing reply from import status service: TypeError: logReplies.forEach is not a function might be an issue with the CLI breaking when something else errors in the background. Not the source of the issue, but rather just not handling it correctly and displaying it in the shell.
    – Liam
    Mar 30 at 13:52
  • logReplies.forEach does not exist in the codebase. It looks like it is from the "import status service" which I assume is part of the JSS Headless Services Packages.
    – Liam
    Mar 30 at 14:43
1

The global jss cli version on the machine was correctly 16.0.0, meanwhile the jss cli version declared in the project's package.json was 15.x.x, updating the package.json to ^16.0.0 and and a fresh npm i seemed to do the trick!

1

I have got the same error for the Sitecore 10.x version. I have followed the below steps to resolve the error:

  1. Uninstall npm Sitecore JSS in global and local path(where your code placed)
    npm uninstall -g @sitecore-jss/sitecore-jss-cli
    npm uninstall -i @sitecore-jss/sitecore-jss-cli
  1. Again install the Sitecore JSS package.
    npm install -g @sitecore-jss/sitecore-jss-cli@16.0.0
    npm install -i @sitecore-jss/sitecore-jss-cli@16.0.0

The version mentioned should match with the installed packages Sitecore Headless Services Server for Sitecore 10.1.0 XM 16.0.0 rev. 210223.zip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.