2

Using - Sitecore.Commerce.Container.SDK.2.0.159

We were able to successfully install Sitecore XP 10.1 in docker on our local machine running on Windows 10 64-bit.
However, when we tried to install Sitecore Commerce 10.1 in the docker, the installation fails.

There is a "solr-init" error in the process.

ERROR: for solr-init  manifest for scr.sitecore.com/sxc/sitecore-xc0-solr-init:10.1-ltsc2019 not found: manifest unknown: manifest tagged by "10.1-ltsc2019" is not found
ERROR: manifest for scr.sitecore.com/sxc/sitecore-xc0-solr-init:10.1-ltsc2019 not found: manifest unknown: manifest tagged by "10.1-ltsc2019" is not found

enter image description here

2
  • 1
    Please include the error message as text, not an image. Google will never find this. – Mark Cassidy Apr 8 at 13:17
  • 1
    @MarkCassidy great point! I added the text version of the error in the image. Thank you for bringing it up. – Alessandro Faniuolo Apr 8 at 14:01
3

Checking the official Sitecore images tags list, it seems that the sitecore-xc0-solr-init image is missing. You should open a ticket with Sitecore Support to let them know that it is missing.

In the meantime, you can update the image name of the solr-init service in your docker-compose.yml file to use the existing sitecore-xc1-solr-init image instead (xc1 instead of xc0) or use the container deployment specs for XC1. The scaling of the XC topology should not have any impact on the Solr initialization job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.