0

Using XP 10.1 & XC 10.1 in my local machine. I've created a new template (Vehicle) with a field (StoreID) using the composer.
In this file, added the following policy:

C:\inetpub\wwwroot\CommerceMinions_Sc\wwwroot\data\Environments\PlugIn.Search.Solr.PolicySet-1.0.0.json

{
   "$type": "Sitecore.Commerce.Plugin.Search.Solr.SolrIndexFieldConfiguration,
            Sitecore.Commerce.Plugin.Search.Solr",
   "Name": "stringpropertyindexname",
   "Type": "System.String",
             "Handler": {
               "$type": "Sitecore.Commerce.Plugin.Catalog.ComposerFieldHandler,Sitecore.Commerce.Plugin.Catalog",
               "ComposerSource": {
               "ViewName": "Vehicle",
               "PropertyName": "StoreID"
     }
   }
}
  • Bootstrapped using Postman
  • Rebuilt the master index because using only the master DB.
  • In the Solr search results, this is how it is:

enter image description here

I have realized and replaced that name in the policy - "stringpropertyindexname" to "StoreID", bootstrapped and rebuilt the master index.
The field name doesn't change in the Solr results.

  1. Am I adding the policy in the correct environment.
  2. In Postman environment settings, all the environments point to Authoring.

enter image description here

EDIT:

I have also added this patch config.

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:search="http://www.sitecore.net/xmlconfig/search/" xmlns:role="http://www.sitecore.net/xmlconfig/role/">
  <sitecore role:require="Standalone or ContentDelivery or ContentManagement" search:require="solr">
    <contentSearch>
      <indexConfigurations>
        <defaultSolrIndexConfiguration type="Sitecore.ContentSearch.SolrProvider.SolrIndexConfiguration, Sitecore.ContentSearch.SolrProvider">
          <fieldMap type="Sitecore.ContentSearch.SolrProvider.SolrFieldMap, Sitecore.ContentSearch.SolrProvider">
            <fieldNames hint="raw:AddFieldByFieldName">
              <field fieldName="StoreID" storageType="YES" indexType="TOKENIZED" vectorType="NO" boost="1f" returnType="string" settingType="Sitecore.ContentSearch.SolrProvider.SolrSearchFieldConfiguration, Sitecore.ContentSearch.SolrProvider"/>
            </fieldNames>
          </fieldMap>
        </defaultSolrIndexConfiguration>
      </indexConfigurations>
    </contentSearch>
  </sitecore>
</configuration>
3
  • 1
    did you update it at both places? I mean in Sitecore configs as well? – Gaurav Agarwal Apr 23 at 7:24
  • @Gaurav Oh yes, I did. I will update the question. – Qwerty Apr 23 at 7:26
  • 1
    try to remove indexes from the master/web core and rebuild the index again – Gaurav Agarwal Apr 23 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.