0

I've enable Language Fallback and everything works as expected on CM, but things are not working out on CD.

  1. I've checked the config to be the same on both CM and CD (/App_Config/Sitecore/CMS.Core/Sitecore.LanguageFallback.config)

  2. Languages in Sitecore have the fallback language setup and (re)published.

Other settings I didn't do. Am I missing something?

2
  • 1
    Worth double checking whether your web db indeed has the published changes as expected.
    – Julius A
    May 4, 2021 at 14:36
  • 1
    You might have missed publishing templates, items... that need the fallback enabled flag on. Try publishing everything.
    – Gatogordo
    May 4, 2021 at 14:38

1 Answer 1

3

You need to configure four settings:

  • Enable site-level language fallback
  • Specify the language fallback rules
  • Enable item level fallback
  • Enable field level fallback

Sounds like you have configured the first two settings (please ensure you are looking at the correct version of Sitecore too)

Please ensure you review this full list here

3
  • 1
    I deployed a patch which enables site-level language fallback and that was it.
    – iusmar
    May 5, 2021 at 14:55
  • 1
    Great to know this worked, cheers!
    – Julius A
    May 5, 2021 at 16:53
  • Thank you. Cheers.
    – iusmar
    May 6, 2021 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.