I've got a multilist with search field in Sitecore 9.2 that does not return all of the items I know it should be. The field source is StartSearchLocation=[ID of folder]&Filter=_templatename:[template name]. This does return a number of records, but not all.

I've confirmed the record I'm looking for is in my Sitecore indexes, and we do have custom indexes and the record is in there as well. It's not marked unpublishable or the like. My MaxItems value in settings is 0, so all records should be returned. I've seen some other answers to similar questions but the solutions I've tried from those usually make the source list disappear entirely.

  • Rebuilding indexes should update it May 7, 2021 at 15:13
  • I rebuilt sitecore_master_index and even did a republish, the item still doesn't appear. May 11, 2021 at 11:23
  • Rebuilt custom indexes too? Depending on the item location and crawling settings on custom index, Sitecore will use different indexes for multi list with search. May 11, 2021 at 12:34
  • Can you try to see if the item is appearing if you add &fq=_indexname:sitecore_master_index at the end of your field source query? Is the item appearing if you remove the &Filter=_templatename filter? May 11, 2021 at 12:47
  • @CristiVulturar Your suggestion was at least a "do no harm" version of one I'd seen elsewhere. Oddly the folks I was looking for finally showed up, so I wonder if unlocking them and the reindex just needed a little time to fully kick in. I'll keep that in mind if someone else is missing as a first check-step. Thanks! May 12, 2021 at 13:41

1 Answer 1


You need to increase the Multilist Item Field Limit by updating this setting in Sitecore.config: <setting name="Query.MaxItems" value="100" />

  • As I noted, it's set to 0 now, which should be no limitation. Unless that changed and I just need to set it to a very high number? May 11, 2021 at 11:22
  • Setting it to higher number solved the issue for me. Didn't try the 0 option. May 11, 2021 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.