0

Using Sitecore 9.3 - just implementing workflow. In the Experience Editor, workflow commands appear in the blue information bar. They are working, but after performing any of these command: Submit, Reject, Approve, etc., the change is not reflected in the information bar until I do a full refresh of the page. It seems like the command to load this state is somehow cached, but I cant figure out how or why.

  1. What command (Looking at the Network tab in the browser tools) is loading the workflow state?
  2. Why is this information not updating when executing a command?

UPDATE

  • The workflow I am using is basically a copy of the Sample Workflow that comes with Sitecore, but we removed the autopublish upon approval.
  • Workflow is working, even through the Experience Editor. Its really only the onscreen messaging in the Experience Editor that is lagging.
  • I dont see any errors, but that is why I was asking about what command gets called when I click on "Submit" to submit the item for approval from the Experience Editor. My suspicion is that the response of this command is somehow cached, but I cant figure out what command it is.
  • As an experiment, I tried using the Sample Workflow, to see if maybe something was configured incorrectly on my workflow, but the same problem happens.
3
  • Can you add more details about the workflow that you are using and how those actions are configured and also if you have any errors happening in browser console? Have you tried to see if for example the sample workflow is working correctly as by default each workflow action should refresh the page? – Cristi Vulturar May 11 at 12:33
  • Is this on your local dev? If so, are you running Live Mode? – Mark Cassidy May 11 at 22:44
  • FACE PALM!!!! Can you add that as an answer? So I can mark it accepted. – Ethan Schofer May 12 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.