2

I'm using Sitecore 9.1.1. I ran into an issue related to the layout of a page.

I have a template which I added a snippet on its standard values' presentation details in the shared layout, this snippet contains 1 rendering (breadcrumb)

enter image description here

enter image description here

When I create an item of this template and I check the presentation details, I can see that the snippet is added on both the shared and final layout as expected.

However, the problem is, sometimes I find that at some point the final layout gets populated with an extra rendering (the breadcrumb) which is the one originally added on the snippet item that is coming from the standard values, even though I didn't manually add that extra rendering again here!

(below are screenshots from the presentation details tabs of the page created from that template after working on the final layout and adding other renderings)

enter image description here

enter image description here

I'm not really sure what triggers the snippet's renderings to be re-added to the page's final layout again!

Could anyone help telling me what might cause this behavior or how to track it down?

1
  • 1
    This might be a bug, I encountered a similar bug with snippets and Sitecore confirmed that was a bug, I would recommend opening a Sitecore ticket and recording a demo. Jun 1 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.