1

When I open page in experience editor it takes 3 to 4 minutes to load the page . Is there any suggestions to improve performance of the page in EE?

1
1

It always takes a lot of time to load Experience Editor first time, but if you experiencing this problem each page refresh, then you can try:

  1. Set "WebEdit.ShowNumberOfLockedItemsOnButton" setting to "false"
  2. Set "ContentTesting.AutomaticContentTesting.Enabled" setting to "false"

Note: each version of the Sitecore might require different fixes.

0

There can be too many root causes. If you don't find the solution in the links that have been shared with you, I would recommend that you do your own research, each instance is a different world.

  1. Enable and check the Sitecore pipeline profiler.
  2. Open the page in debug mode (Sitecore).
  3. Use advanced tools (dotTrace, ANTS, Visual Studio, etc).

Sometimes it's a custom (bad) code implemented on any of your custom components that take long to execute. There is a data source query that is very expensive, etc.. Root causes can be infinite, but those tools would definitely help you to find and fix your performance issues.

Not the answer you're looking for? Browse other questions tagged or ask your own question.