0

I am trying to integrate Sitecore Connect for Content Hub and following the installation guide. When I am creating an entity in Content Hub, it is properly triggering it to Azure Service Bus but getting below exception in Sitecore log.

188272 22:04:07 INFO  [Sitecore Connect for Content Hub]: Getting an entity by id: 33711. Attempt #1.
188272 22:04:07 ERROR [Sitecore Connect for Content Hub]: The M-Entity (id: 33711) was not found in M.
Exception: System.InvalidOperationException
Message: The M-Entity (id: 33711) was not found in M.
Source: Sitecore.Connector.CMP
   at Sitecore.Connector.CMP.Helpers.CmpHelper.GetEntity(Int64 entityId, BaseLog logger)
   at Sitecore.Connector.CMP.Pipelines.ImportEntity.FetchEntity.Process(ImportEntityPipelineArgs args, BaseLog logger)
   at Sitecore.Connector.CMP.Pipelines.ImportEntity.ImportEntityProcessor.Process(ImportEntityPipelineArgs args)

Any pointer would highly be appreciated.

2
  • Have you checked if the CH instance settings in XP are correct? It can't find the entity (by id 33711) in the content hub instance it's pointing to.
    – josedbaez
    Jul 1 at 13:06
  • Good catch @josedbaez. Thanks for giving me a direction to look into this. I will check again and will let you know. Jul 2 at 6:36
1

Finally, I got the root cause of it. Everything was configured correctly but the user, which is being used to communicate to Content Hub, was not having proper rights to access those CMP items. I just added proper roles and it worked.

We just need to make sure that the user has enough access rights to the relevant area. In my case, I have given all available administrator access under the "User Group" section along with the superuser.

enter image description here

Many thanks to @josedbaez for his clue.

3
  • You don't need anything else if you add superusers user group. Do note: that user group allow users to do anything.
    – josedbaez
    Jul 6 at 8:22
  • Agreed. Thank you. You can post this as an answer and I would be happy to mark that as an answer. Jul 6 at 9:03
  • No need, you found the answer youself. Happy you managd to solve it.
    – josedbaez
    Jul 6 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.